
第3章

STM32CubeIDE集成开发环境

本章重点讲述STM32CubeIDE集成开发环境的使用方法和具体操作细节。首先,介
绍STM32CubeIDE的基本概念及其安装准备工作,包括软件包获取、安装流程、启动软件

和打开项目,确保读者掌握基础操作。
在界面功能和操作部分,本章详细解析C/C++开发环境中的主要视图、工具栏功能以

及文本编辑器的操作,使读者能够高效利用STM32CubeIDE进行代码编写和调试;
 

同时,
介绍STM32CubeMX生成项目的文件组成,解释包括CMSIS驱动程序文件、HAL驱动程

序文件、用户程序文件、启动文件及根目录下的文件的具体内容,并讲解Include搜索路径

的设置。
本章通过说明File、Edit、Source、Refactor、Navigate、Search、Project、Run、Window和

Help菜单的各项功能,使读者全面掌握STM32CubeIDE的多样化操作方法。
在实际操作部分,涵盖了新建、导入、管理、切换、删除和导出工程,以及固件库管理、代

码编译、调试和运行配置、启动调试等,逐步指导读者完成开发全过程。
此外,本章还指导读者如何使用内置的STM32CubeMX进行项目创建、MCU配置

和代码生成,提供图形化配置的便利性。最后,介绍STM32CubeIDE的使用偏好设置

以及推荐的STM32F407开发板和仿真器选择,为读者实际开发提供硬件参考和优化

方案。
通过本章的学习,读者将全面了解STM32CubeIDE的安装与使用,从而大幅提升基于

STM32微控制器的开发效率。

3.1 STM32CubeIDE基本介绍

STM32CubeIDE是STM32Cube
 

生态系统中的一个重要软件工具,是ST官方免费提

供的STM32
 

MCU/MPU程序开发IDE软件。ST公司最初并没有自己的STM32开发

IDE软件,为了完善STM32Cube生态系统中这重要的一环,ST公司在2017年年底收购了

Atollic公司,将专业版 TrueSTUDIO 改为免费的。2019年4月,ST 公司正式推出了

STM32CubeIDE
 

1.0.0。
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  STM32CubeIDE就是在TrueSTUDIO的基础上改进和升级得来的,具有如下特点。
(1)

 

STM32CubeIDE使用Eclipse
 

IDE,具有强大的编辑功能,其使用习惯与TrueSTUDIO
相同。

(2)
 

STM32CubeIDE使用GNU
 

C/C++编译器,支持在STM32项目开发中使用C++

编程。
(3)

 

STM32CubeIDE内部集成了STM32CubeMX,在STM32CubeIDE里就可以进行

MCU图形化配置和代码生成,然后在初始代码的基础上继续编程。当然,STM32CubeIDE
也可以和独立的STM32CubeMX配合使用。

正式推出STM32CubeIDE后,ST公司就不再更新TrueSTUDIO了,新的设计推荐使

用STM32CubeIDE。
用户可以从ST公司网站下载最新版STM32CubeIDE的安装文件。安装文件中只有

一个可执行文件,双击运行就可以开始安装。
为提升功能丰富且高能效的STM32系列微控制器的易用性,2019年,ST公司在

STM32Cube软件生态系统中增加了一个免费的多功能STM32开发工具———STM32CubeIDE。

STM32CubeIDE是ST官方提供的免费软件开发工具,也是STM32Cube生态系统的

核心。它基于Eclipse/CDT框架、GCC编译工具链和GDB调试工具,支持添加第三方功能

插件。同时,STM32CubeIDE还集成了部分STM32CubeMX和STM32CubeProgrammer
的功能,是一个“多合一”的STM32开发工具。STM32CubeIDE架构如图3-1所示。

图3-1 STM32CubeIDE架构

用户只需要STM32CubeIDE这一个工具,就可以完成从芯片选型、项目配置、代码生

成,到代码编辑、编译、调试和烧录的所有工作。

STM32CubeIDE基于Eclipse的框架,它继承了Eclipse所特有的特性,如工作空间、透
视图等。STM32CubeIDE软件界面如图3-2所示。
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图3-2 STM32CubeIDE软件界面

3.2 STM32CubeIDE使用前的准备

在使用STM32CubeIDE之前,开发者需要进行一系列准备工作以确保开发环境的顺

利搭建和项目的成功实施。详细步骤如下。

1)
 

硬件准备

(1)
 

开发板。选择适合项目需求的STM32开发板,如Nucleo、Discovery或Evaluation板。
(2)

 

调试工具。确保有合适的调试器,如ST-LINK/V2。
(3)

 

连接线。USB线用于连接开发板和计算机。

2)
 

软件准备

(1)
 

安装STM32CubeIDE。从STMicroelectronics官方网站下载最新版本的STM32CubeIDE
安装包,并根据操作系统(Windows、macOS或Linux)的指引进行安装。

(2)
 

下载并安装驱动程序。安装ST-LINK
 

USB驱动程序,以确保调试器和计算机之

间的通信正常。

3)
 

必要配置

(1)
 

安装STM32CubeMX。虽然STM32CubeIDE内置了STM32CubeMX功能,但确

保STM32CubeMX插件是最新版本,有助于生成初始化代码和配置外设。
(2)

 

获取相关固件包。在STM32CubeIDE中,通过Help→Manage
 

embedded
 

software
 

第9集
微课视频
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packages菜单命令下载和管理对应的STM32固件包。

4)
 

开发板设置

(1)
  

接电与连接。将开发板通过USB线连接到计算机,并确认跳线设置正确。
(2)

 

调试器配置。打开STM32CubeIDE并确保能识别到连接的调试器ST-LINK/V2。

5)
 

初步项目配置

(1)
 

启动STM32CubeIDE。打开STM32CubeIDE并创建一个新工作空间以存放项目

文件。
(2)

 

新建项目。使用STM32CubeMX创建一个新项目,选择对应的STM32芯片或开

发板,配置时钟和外设,并生成初始化代码。
(3)

 

导入IDE。STM32CubeMX生成的项目自动导入STM32CubeIDE。

6)
 

编译与调试准备

(1)
 

编 译 器 配 置。确 保 GNU
 

Arm
 

Embedded
 

Toolchain 正 确 安 装 并 配 置 在

STM32CubeIDE中。
(2)

 

项目编译。在STM32CubeIDE中完成项目编译,确认无编译错误。
(3)

 

调试设置。配置调试器选项,确保能够进行单步调试和断点设置。

7)
 

学习与实践

熟悉STM32CubeIDE的用户手册和参考文档,了解各项功能和使用技巧。

8)
 

示例项目

参考STM32Cube提供的示例项目,帮助快速上手和理解STM32开发流程。
通过以上步骤,开发者可以为使用STM32CubeIDE做好充分准备,建立一个高效、可

靠的开发环境。

3.2.1 STM32CubeIDE软件包获取

在安装STM32CubeIDE之前,首先登录ST公司官网(https://www.st.com.cn/zh/

development-tools/stm32cubeide.html#),选 择 STM32CubeIDE 安 装 包 版 本 (如

STM32CubeIDE1.15.1)。如图3-3所示,单击“获取软件”按钮,进入STM32CubeIDE安装

包下载许可协议选择页面,需要登录 MyST,与STM32CubeMX的操作方式相同,这里

从略。
下载到的STM32CubeIDE安装包如图3-4所示。

3.2.2 STM32FCubeIDE的安装

STM32FCubeIDE安装步骤如下。
将STM32CubeIDE安装包解压缩后,得到如图3-5所示的STM32CubeIDE应用程序。
双击st-stm32cubeide_1.15.1_21094_20240412_1041_x86_64.exe应用程序,弹出如

图3-6所示的STM32CubeIDE安装向导。
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图3-3 STM32CubeIDE安装包下载页面

图3-4 STM32CubeIDE安装包
  

图3-5 STM32CubeIDE应用程序

图3-6 STM32CubeIDE安装向导
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单击Next按钮,弹出如图3-7所示的License
 

Agreement(许可协议)界面。
单击I

 

Agree按钮,弹出如图3-8所示的Choose
 

Install
 

Location界面,选择安装路径。

图3-7 License
 

Agreement(许可协议)界面 图3-8 Choose
 

Install
 

Location界面

一般选择默认路径,单击Next按钮,弹出如图3-9所示的Choose
 

Components(选择组

件)界面。
单击Install按钮,弹出如图3-10所示的Installing(安装)界面。

图3-9 Choose
 

Components(选择组件)界面 图3-10 Installing(安装)界面

在STM32CubeIDE安装过程中,会弹出如图3-11所示的STMicroelectronics通用串

行总线设备安装选择对话框。
由于在应用STM32CubeIDE开发调试时,要将ST-LINK/V2插入计算机的 USB接

口,所以单击“安装”按钮,返回Installing界面继续安装,如图3-12所示。

STM32CubeIDE安装完成,弹出如图3-13所示的Installation
 

Complete界面。
单击Next按钮,弹出如图3-14所示的创建桌面快捷方式界面。
勾选Create

 

desktop
 

shortcut复选框,单击Finish按钮,在计算机桌面生成如图3-15
所示的STM32CubeIDE快捷方式。
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图3-11 STMicroelectronics通用串行总线设备安装选择对话框

图3-12 继续安装

图3-13 Installation
 

Complete界面
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图3-14 创建桌面快捷方式界面

 

  
图3-15 STM32CubeIDE快捷方式

3.2.3 启动软件

双击STM32CubeIDE快捷方式启动软件。
在STM32CubeIDE启动时,会弹出如图3-16所示的STM32CubeIDE

 

Launcher对话

框,要求设置一个工作空间目录。

图3-16 STM32CubeIDE
 

Launcher对话框

STM32CubeIDE的工作空间(Workspace)是一个包含项目、设置和资源的文件系统目

录。工作空间的主要功能和特点如下。
(1)

 

项目管理。工作空间是所有项目存储的地方,可以包含多个不同的项目。每个项

目都包含特定的源代码、配置文件和其他相关的资源。
(2)

 

独立配置。每个工作空间都有其独立的配置文件,这些文件保存了与具体开发环

境相关的设置,如构建配置、调试配置、编辑器设置等。
(3)

 

资源组织。工作空间提供了一种组织和管理项目资源的方式,帮助开发者方便地

浏览和查找项目文件夹和文件。
(4)

 

插件和扩展。与工作空间关联的配置文件中还包含了各种插件和扩展的设置和数

据,这些插件扩展了IDE的功能。
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(5)
 

灵活性。开发者可以创建并切换多个工作空间,以适应不同的开发需求或项目。
这允许他们在不同项目或任务间彼此独立地管理和跟踪设置。

简而言之,STM32CubeIDE的工作空间是一个为开发者提供组织、管理和定制开发环

境的基础架构,使他们能够高效地处理多个项目和资源。
例如,一些示例项目都放在F:\Demo\CubeIDE目录下,这个目录就是工作空间目录。

启动STM32CubeIDE后,设置工作空间(Workspace)目录,如图3-16所示。单击Browse
按钮选择这个目录,然后单击Launch按钮启动软件。

另外,也可以执行File→Switch
 

Workspace菜单命令切换工作空间,如图3-17所示。

图3-17 切换工作空间

启动STM32CubeIDE打开一个新的工作空间后,会显示如图3-18所示的信息中心页

面。这个页面中有创建STM32CubeIDE项目的快捷按钮,这些功能的具体操作在后面会

介绍。

图3-18 信息中心页面

(1)
 

Start
 

new
 

STM32
 

project:
 

开始创建一个新的STM32项目。
(2)

 

Start
 

new
 

project
 

from
 

STM32CubeMX
 

file(.ioc):
 

从STM32CubeMX的*.ioc
文件开始创建一个项目。



90   

(3)
 

Import
 

project:
 

导入STM32工程项目。
(4)

 

Import
 

STM32Cube
 

example:
 

导入STM32Cube示例。
信息中心页面右侧的Support

 

&
 

Community区域有一些支持和社区网站的链接,单击

后可在系统默认的浏览器中打开。

Quick
 

links区域有一些技术资料的 PDF文档或 HTML网页的链接,单击 Read
 

STM32CubeIDE
 

Documentation后会打开一个文档列表页面,有更多有用的技术文档,包
括STM32CubeIDE的用户手册等,用户在编程时可以查阅这些资料文档。

3.2.4 打开项目

本节以项目ADC为例,讲解STM32CubeIDE软件的基本使用方法以及STM32CubeIDE
项目的文件组成。

首先关闭信息中心页面,然后执行File→Open
 

projects
 

from
 

file
 

system菜单命令,会
弹出如图3-19所示的Import

 

Projects
 

from
 

File
 

System
 

or
 

Archive对话框,这个对话框用

于将一个项目导入当前工作空间中。

图3-19 Import
 

Projects
 

from
 

File
 

System
 

or
 

Archive对话框

在Import
 

Projects
 

from
 

File
 

System
 

or
 

Archive对话框中,首先单击Directory按钮,
选择示例目录下项目

 

ADC的根目录。选择后会在Import
 

source文本框里显示此目录,并
将项目名称显示在下方的列表里。其他设置保持默认设置,最后单击Finish按钮,就可以

打开项目ADC了。
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打开项目ADC后的STM32CubeIDE
 

界面如图3-20所示。

图3-20 打开项目ADC后的STM32CubeIDE界面

3.2.5 STM32CubeIDE的一些基本概念

STM32CubeIDE是基于Eclipse的IDE软件,与一般的编程开发IDE界面类似。如果

读者对Eclipse比较熟悉,那么对STM32CubeIDE的操作也就很容易上手了;
 

如果没有使

用过Eclipse,需要对Eclipse中的一些基本概念有所了解。

Eclipse是一个使用广泛地编程开发IDE,通过使用插件可以支持不同编程语言的开

发,如C/C++、Java、Python等。Eclipse的项目管理和界面组织有一些基本的概念,包括工

作空间、项目、视图、场景。

1.
 

工作空间

STM32CubeIDE通过工作空间(Workspace)对工程进行管理,打开STM32CubeIDE
时,会新建一个默认的工作空间,用户也可以通过单击Browse按钮另外选择一个文件夹作

为工作空间,之后新建或导入的工程就都属于前面选择的这个工作空间。同一个工作空间

下的工程具有相同的IDE层面的配置(通过 Window→Preferences菜单命令进行设置),如
显示和编辑的风格设置等。
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工作空间是多个项目(Project)的集合,一个工作空间对应一个实际的目录。例如,在
图3-16中设置了一个工作空间为目录F:\Demo\CubeIDE,这个目录下的子目录的构成如

图3-21所示。

图3-21 一个工作空间的目录组成

在这个工作空间目录下,有STM32CubeIDE为工作空间自动创建的.metadata文件

夹,用于存放工作空间IDE的各种配置文件,以及工作空间所管理的项目的信息文件。
在工作空间目录下,可以有多个STM32CubeIDE项目文件夹,STM32CubeIDE项目名

称就是文件夹名称。
一个工作空间管理的项目最好就放在这个工作空间的目录下,虽然也可以将非工作空

间目录下的项目导入工作空间中。
在STM32CubeIDE中,任何时候只能打开一个工作空间。用户可以在STM32CubeIDE启

动时的对话框里选择工作空间,也可以在运行时通过执行File→Switch
 

Workspace菜单命

令切换当前工作空间。

2.
 

项目(Project)
一个STM32CubeIDE项目(Project)就是一个文件夹下的所有子目录和文件的集合,

项目的名称就是文件夹的名称。一个项目包含很多文件和子目录。例如,项目1-LED根目

录下的文件和子目录构成如图3-22所示,项目1-LED/STM32CubeIDE根目录下的文件和

子目录构成如图3-23所示。项目目录下的子目录/.settings是自动生成的用于管理项目信

息的子目录,几个没有名称只有扩展名的文件是项目管理的相关文件,如.cproject、

.mxproject和.project。LED.ioc是STM32CubeMX项目文件。其他文件和子目录就是

STM32编程相关的用户程序文件和驱动程序文件。

图3-22 项目1-LED根目录下的文件和子目录构成
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图3-23 项目1-LED/STM32CubeIDE根目录下的文件和子目录构成

1)
 

.project文件和.cproject文件

在STM32CubeIDE中,.project文件和.cproject文件是Eclipse工程的一部分,因为

STM32CubeIDE基于Eclipse平台。这些文件包含了项目的不同配置和设置。

.project文件主要描述工程的通用信息和元数据,包括工程名称、工程类型、与工程相

关的配置信息插件、构建配置等信息。在Eclipse中打开工程时,会读取这个文件识别工程

以及加载必要的插件和工具。

.cproject文件主要描述与C/C++开发相关的配置信息,包括编译器、链接器的设置,以
及源码路径,包含路径、宏定义、构建变量等详细信息。在编译和链接工程时,Eclipse会参

考这个文件中的设置以确定如何处理源代码和生成最终的可执行文件。
也就是说,.project文件是描述工程元数据和通用设置的文件;

 

.cproject文件是描述

与C/C++开发相关详细配置的文件。这两个文件相辅相成,确保STM32CubeIDE能够正

确地理解和构建你的工程。

2)
 

.launch文件

图3-23中,有一个LED
 

Debug.launch文件。LED
 

Debug.launch文件通常是一个基

于Eclipse
 

IDE的启动配置文件,它专门为调试一个LED控制项目而创建。此类文件包含

了与调试该项目相关的详细配置,如目标板信息、调试器设置、硬件接口等。
在Eclipse平台上(包括基于Eclipse的IDE,如STM32CubeIDE、RT-Thread

 

Studio
等),.launch文件主要用于保存特定项目的运行配置。这些文件通常包含运行或调试应用

程序所需要的信息。

.launch文件的作用如下。
(1)

 

保存运行配置。.launch文件保存了如何启动、运行或调试项目的详细配置,包括启

动程序的入口点、必要的环境变量、程序参数、工作目录等信息。
(2)

 

支持多种启动模式。可以创建多个.launch文件以支持不同的启动模式。例如,一
个.launch文件可以用来在本地调试程序,另一个.launch文件可以用来在远程服务器上运

行同一个程序。
(3)

 

简化项目运行。因为.launch文件记录了所有需要的配置信息,可以通过单击按钮

快速启动应用程序,而无须每次手动输入参数或配置环境。
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.launch文件包含的信息如下。
(1)

 

项目名称:
 

与该配置相关的Eclipse项目名称。
(2)

 

主类或启动文件:
 

指定要运行的入口类(对于Java项目)或启动文件。
(3)

 

VM参数或程序参数:
 

用于指定虚拟机或应用程序所需的参数。
(4)

 

环境变量:
 

运行该项目所需的环境变量。
(5)

 

工作目录:
 

项目运行时所使用的工作目录。
(6)

 

调试配置:
 

如果用于调试,文件还会包含调试相关的设置,如断点信息、日志文件等。

.launch文件用于保存和管理项目的运行和调试配置,是Eclipse平台及其衍生IDE中

的一个重要功能。这些文件帮助开发者快速、方便地在各种配置下启动和调试项目,提升了

开发效率。

3.
 

视图

STM32CubeIDE界面上有很多子窗口,这些子窗口称为视图(View)。例如,界面左侧

显示项目目录和文件组成的Project
 

Explorer视图,界面右侧显示文件概览的 Outline视

图。一个视图就是实现一些功能的窗口,通常显示在一个多页组件上,右上角有关闭视图的

按钮。

STM32CubeIDE是功能强大的IDE,有很多视图,用户可根据需要选择显示各种视图。
执行 Window→Show

 

View菜单命令,会显示如图3-24所示的子菜单,其中会显示一些常

用的视图。例如,SFRs是显示 MCU 的特殊寄存器内容的视图,在调试程序时有用;
 

Outline是显示一个文件内代码概览的视图,可以显示文件内的函数、宏、类型、变量等各种

定义,在浏览程序时特别有用。
如果单击最后的Other菜单项,会弹出如图3-25所示的Show

 

View对话框,这个对话

框里分类列出了所有视图。

图3-24 常用视图菜单
   

图3-25 Show
 

View对话框
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4.
 

场景

STM32CubeIDE的视图非常多,都显示出来会很杂乱,且在工作状态切换时逐个打开

或关闭视图效率低下。例如,编程状态和调试状态要用到不同的视图。因此,Eclipse使用

场景(Perspective)管理视图。场景就是多个视图组成的一种工作界面,一个场景一般对应

于一种工作需求,例如,C/C++场景是最常用的场景,图3-20显示的就是这个场景;
 

Debug
场景是用于程序调试时的工作场景。

执行 Window→Perspective菜单命令,会显示如图3-26所示的子菜单。单击Customize
 

Perspective菜单项,可以打开一个对话框对当前场景进行定制,定制内容包括工具栏按钮

和菜单项的可见性,可以保存定制的场景并自定义场景名称。
在图3-26中,单击Perspective→Open

 

Perspective→Other菜单项,会弹出如图3-27所

示的Open
 

Perspective对话框,其中有STM32CubeIDE预定义的场景。在工作状态变化

时,场景一般会自动切换。例如,STM32CubeIDE启动后就处于C/C++场景,这是最常用的

场景;
 

如果在项目管理器里双击STM32CubeMX文件 ADC.ioc,会自动切换到 Device
 

Configuration
 

Tool场景,也就是内置的STM32CubeMX操作界面;
 

如果下载程序开始调

试,会自动切换到Debug场景。

图3-26 场景管理子菜单 图3-27 Open
 

Perspective
 

对话框

3.2.6 STM32Cube软件库设置

STM32CubeIDE集成了STM32CubeMX的功能,因为需要用到STM32Cube
 

MCU固

件库和扩展库(统称为软件库),所以要设置软件库的存储路径和升级方式。执行 Window→
Preferences菜单命令,弹出Preferences对话框。用户在这个对话框里可以对软件的各种特

性进行设置,包括界面配色方案、字体等。STM32Cube软件库相关的设置在STM32Cube→
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Firmware
 

Updater页面,设置结果如图3-28所示。

图3-28 Preferences对话框

主要的设置内容包括以下几项。
(1)

 

将软件库目录设置为C:/Users/lenovo/STM32Cube/Repository/,也就是与独立

的STM32CubeMX软件共用软件库。
(2)

 

Check
 

and
 

Update
 

Firmware
 

packs
 

Settings是软件库的更新检查方式,设置为

Manual
 

Check(手动检查)。
(3)

 

Target
 

Selector
 

Device
 

Database
 

Auto-Refresh是数据和文档的刷新方式,设置为

No
 

Auto-Refresh
 

at
 

Application
 

start(应用程序启动时不自动刷新)。
每次新建一个工作空间时,其STM32Cube的软件库位置和升级方式将恢复为默认值。

所以,如果要使用内置的STM32CubeMX修改 MCU配置并生成代码,要注意在新建工作

空间时重新设置软件库位置和升级方式。

Help主菜单下有几个与STM32CubeMX相关的菜单项,包括以下几项。
(1)

 

Check
 

for
 

Updates(检查更新):
 

会打开一个对话框,用于检查STM32Cube
 

MCU
 

固件包和嵌入式软件包的更新。
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(2)
 

Manage
 

Embedded
 

Software
 

Packages(管理嵌入式软件包):
 

执行 Help→Manage
 

Embedded
 

Software
 

Packages菜单命令,如图3-29所示。

图3-29 Help→Manage
 

Embedded
 

Software
 

Packages菜单命令

弹出如图3-30所示的Embedded
 

Software
 

Packages
 

Manager(嵌入式软件包管理器)
对话框,对 MCU 固件包和其他嵌入式软件包进行管理。这个对话框的功能与独立的

STM32CubeMX软件中的嵌入式软件包管理器的功能相同,这里不再赘述。

图3-30 Embedded
 

Software
 

Packages
 

Manager对话框
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3.3 C/C++场景的界面功能和操作

STM32CubeIDE是基于Eclipse的集成开发环境,专为开发STM32微控制器而设计。
它提供了多种功能,帮助用户快速进行嵌入式系统开发。STM32CubeIDE的C/C++场景的

一些主要界面功能和操作如下。

1)
 

项目创建和管理

(1)
 

新建项目:
 

通过执行File→New→STM32
 

Project菜单命令创建新项目,选择目标

芯片或开发板,并进行基本设置。
(2)

 

项目资源管理器:
 

在Project
 

Explorer视图中浏览和管理项目文件、源代码和头

文件。

2)
 

编辑器

(1)
 

代码编辑:
 

提供语法高亮、错误和警告提示、代码自动补全等功能。
(2)

 

跳转功能:
 

按住Ctrl键并单击函数名或变量名,可以快速跳转到定义或声明处。
(3)

 

注释/取消注释:
 

使用Ctrl+/快捷键注释或取消注释选定的代码行。

3)
 

调试功能

(1)
 

启动调试:
 

通过执行Run→Debug菜单命令或单击工具栏上的调试按钮,启动调

试会话。
(2)

 

断点管理:
 

在代码行旁边单击即可添加或删除断点,断点在调试时会使程序暂停

执行,以便检查状态。
(3)

 

监视窗口:
 

在调试过程中,Variables视图可显示当前变量的值,Watch视图可手动

添加或观察变量。
(4)

 

单步执行:
 

使用工具栏上的Step
 

Into(F5)、Step
 

Over(F6)、Step
 

Return(F7)按钮

分别进行逐语句、跳过以及返回上一级调用的调试。

4)
 

代码生成和配置

(1)
 

STM32CubeMX配置:
 

集成STM32CubeMX,可以通过图形界面配置芯片的外设

和中间件,然后自动生成初始化代码。
(2)

 

代码生成:
 

STM32CubeMX会根据配置生成HAL(硬件抽象层)库函数调用代码,
帮助用户快速开始开发。

5)
 

终端和控制台

(1)
 

串口终端:
 

通过执行 Window→Show
 

View→Other→Terminal菜单命令打开串口

终端,用于对接串口调试信息。
(2)

 

控制台窗口:
 

显示编译信息和调试输出等日志信息。

6)
 

视图和窗口

(1)
 

Outline视图:
 

显示当前文件的结构,如函数、变量等,帮助快速导航。
(2)

 

Problems视图:
 

列出编译过程中发现的错误和警告信息。

第10集
微课视频
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(3)
 

Project
 

Explorer视图:
 

管理和浏览项目内的文件和文件夹结构。

7)
 

工具和设置

(1)
 

编译选项:
 

通过项目属性(执行Project→Properties菜单命令)进行编译器、链接器

选项和其他构建设置的配置。
(2)

 

插件扩展:
 

作为Eclipse的扩展,STM32CubeIDE允许安装各种Eclipse插件,以增

强功能。
一个操作示例如下。
(1)

 

新建一个STM32项目。打开STM32CubeIDE,执行File→New→STM32
 

Project
菜单命令。在Device

 

Selector中选择目标芯片(如STM32F4系列),然后单击Next按钮。
填写项目名称,选择目标语言(C或C++),然后单击Finish按钮。

(2)
 

配置外设和生成代码。打开项目中自动生成的.ioc文件,会启动STM32CubeMX
配置界面。在配置界面中进行引脚配置、外设初始化等设置。配置完成后,执行Project→
Generate

 

Code菜单命令生成初始化代码。
(3)

 

调试项目。单击工具栏上的Debug按钮启动调试。在代码编辑器中设置断点。使

用调试视图中的单步执行按钮进行调试。

STM32CubeIDE集成了丰富的功能,支持从项目创建、代码编写、外设配置到调试的完

整开发流程,非常适合STM32嵌入式开发。

3.3.1 主要视图

C/C++场景是STM32CubeIDE中最常用的一个场景,图3-20就是C/C++场景的典型

界面,主要有以下几个视图。
(1)

 

Project
 

Explorer视图:
 

显示项目目录下的所有文件夹和文件,用于对项目的文件

夹和文件进行管理。
(2)

 

文本编辑器:
 

位于界面中间,用于显示和编辑各种文本文件,主要是程序文件。在

Project
 

Explorer视图中双击一个文本文件时就可以打开这个文件,并以多页界面显示多个

文件。
(3)

 

Outline视图:
 

显示文本编辑器当前页面中的程序的提纲,如程序中的类型、常量、
变量、函数等。在Outline视图上单击一个符号时,文本编辑器中就会将输入光标定位到这

个符号定义处。Outline视图中有一个工具栏,工具栏上的按钮可以实现排序、符号过滤等

功能。
(4)

 

Console视图:
 

可以显示编译过程和编译结果信息。
(5)

 

Problems视图:
 

可以显示编译过程中出现的警告、错误等信息,双击一个提示信息

就可以在文本编辑器中定位到出错误的代码行。
(6)

 

Build
 

Analyzer视图:
 

可以显示项目构建后Flash、RAM等存储空间的使用情况。
(7)

 

还有其他一些有用的视图,如Tasks视图。
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3.3.2 工具栏功能

STM32CubeIDE的主工具栏按钮会根据场景的变化而变化,如C/C++场景的主工具栏

按钮和Debug场景的差别就较大。主工具栏分为左端和右端两大部分,左端的工具栏是与

文件操作、项目构建和界面操作相关的按钮,右端的工具栏是场景切换操作的按钮。
图3-31所示为C/C++主工具栏左端的按钮,这些按钮的简要功能说明如表3-1所示,

其中标注了备注序号的见后文的详细说明。工具栏上某些按钮并不适合于C/C++场景,或
极少使用,用户可以定制工具栏按钮。执行 Window→Perspective→Customize

 

Perspective
菜单命令,会弹出一个对话框,可供用户自定义场景,设计更适合自己使用习惯的工具栏。

图3-31 C/C++场景主工具栏左端的按钮

表3-1 C/C++场景主工具栏左端的按钮功能说明

按钮图标 提示文字 快捷键 功能说明 备注

New —
出现一个下拉菜单,用于新建

各种项目和文件
(1)

 

Save Ctrl+S
保存文本编辑器里当前页面的

文件
—

Save
 

All Ctrl+Shift+S
保存文本编辑器里所有页面的

文件
—

Manage
 

configurations
 

for
 

the
 

current
 

project
—

选择 项 目 的 配 置 模 式,Debug
模式或Release模式

(2)
 

Build
 

projects
 

Build
 

the
 

active
 

configurations
 

of
 

selected
 

projects

— 构建所选项目的活动配置 (3)
 

Build
 

all Ctrl+B 完全重新构建当前项目 —

Undo Ctrl+Z 撤销

Redo Ctrl+Y 重做

Skip
 

All
 

Breakpoints Ctrl+Alt+B
忽略所有断点,在程序调试时

有用
—

Device
 

Configuration
 

Tool
 

Code
Generation

— 设备配置工具代码 —

New
 

C/C++ project —
出现一个下拉菜单,用于新建

C/C++项目
—

New
 

C/C++ Source
 

Folder —
出现一个下拉菜单,用于新建

源代码文件夹
—
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续表

按钮图标 提示文字 快捷键 功能说明 备注

New
 

C/C++ Source
 

File —
出现一个下拉菜单,用于新建

头文件或源程序文件
—

New
 

C++ Class — 新建C++类 —

Debug
 

As... —
出现一个下拉菜单,用于启动

项目调试
—

Run
 

As... —
出现一个下拉菜单,用于启动

项目运行
—

External
 

Tools
Run

 

Last
 

Tool
—

启动外部工具

运行最后一个工具
—

Open
 

Element Ctrl+Shift+T
打开一个对话框,对元素(Element)
进行查找

(4)
 

Search —
打开一个查找对话框,有3种

类型的搜索
—

Toggle
 

Mark
 

Occurences Alt+Shift+O
切换标记同类项,如一个函数

内一个变量所有出现的实例
—

Toggle
 

Word
 

Wrap Alt+Shift+Y 切换文本自动换行功能 —

Toggle
 

Block
 

Selection
 

Mode Alt+Shift+A 切换文本块选择方式 —

Show
 

Whitespace
 

Character — 切换显示空格符号 —

Next
 

Annotation Ctrl+.

移动到下一标注处,标注包括

书签、断点、编译错误、编译警

告等。有一个下拉菜单可以选

择标注类型

(5)
 

Previous
 

Annotation Ctrl+, 移动到上一标注处 (5)
 

Last
 

Edit
 

Location
Previous

 

Edit
 

Location
Ctrl+Q 定位到最后一次修改的代码处 —

Next
 

Edit
 

Location
Ctrl+Alt+
Right

下一页编辑位置

Back
 

to Alt+Left 代码追踪时回到上一级 —

Forward
 

to
 

Forward Alt+
 

Right 代码追踪时回到下一级 —

Pin
 

Editor —
在文本编辑器当前页面设置或

取消图钉标记
—

Information
 

Center — 显示信息中心页面 —
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表3-1中的几个按钮下拉菜单介绍如下。
(1)

 

New按钮的下拉菜单如图3-32所示。其中,STM32
 

Project菜单项用于打开一个向导,
创建基于STM32

 

MCU/MPU的嵌入式项目;
 

STM32
 

Project
 

from
 

an
 

Existing
 

STM32CubeMX
 

Configuration
 

File(.ioc)菜单项用于从一个已有的STM32CubeMX文件创建项目。

图3-32 New按钮的下拉菜单

(2)
 

一个项目有Debug和Release两种配置,Manage
 

Configurations
 

for
 

the
 

current
 

project按钮用于设置项目当前的配置。若单击按钮右侧的箭头图标,会出现 Debug和

Release
 

两个菜单项,单击菜单项就可以选择。若直接单击按钮,会弹出如图3-33所示的对

话框,用于设置项目的当前配置。
(3)

 

如果直接单击 按钮,会构建项目的当前配置版本。这个按钮也有Debug和

Release两个菜单项,可以选择构建其中某个版本,如图3-34所示。

图3-33 设置项目的当前配置
   

图3-34 构建所选项目的活动配置

(4)
 

单击Open
 

Element按钮,会弹出Open
 

Element对话框,如图3-35所示。可以在

整个项目源代码和驱动库源代码中按关键词搜索,并且限定元素类型,如函数、结构体、类、
宏定义等。例如,在文本框中输入GPIO,可以找到GPIO_InitTypeDef结构体,双击匹配结

果里的这一项,就可以打开其定义所在的源文件,并定位到这个结构体定义的源代码处。
(5)

 

Next
 

Annotation和Previous
 

Annotation这两个按钮有相同的下拉菜单,如图3-36
所示。每个菜单项是一个复选项,用于选择标注的类型。

主窗口右端的工具栏显示最近打开过的场景,通过这些Quick
 

Access按钮可以快速切

换到某个场景。例如,工具栏的按钮可能如图3-37所示。Open
 

Perspective按钮 用于打

开对话框选择场景,后面的3个按钮是最近打开过的3个场景,单击即可切换场景。切换到

某个场景后,主窗口工具栏左端的工具栏按钮会相应调整。
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图3-35 Open
 

Element对话框

图3-36 标注类型选择菜单

 

    
图3-37 场景切换工具栏按钮

工具栏上的 按钮用于快速搜索某个功能。例如,单击按钮后输入Debug,显示的内

容如图3-38所示,列出了所有包含Debug的视图、场景、命令、菜单项等,单击某一项就可以

快速执行其功能。
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图3-38 Quick
 

Access搜索结果

3.3.3 文本编辑器功能和操作

STM32CubeIDE软件界面中间的区域是文本编辑器,主要用于编辑程序文件。这个编

辑器具有强大的编辑功能,下面介绍一些实用的操作功能。

1.
 

界面主题和编辑器字体

执行 Window→Preferences菜单命令,会弹出Preferences对话框,如图3-39所示。在

对话框左侧的目录树中单击某个节点,就会在右侧显示具体的设置页面。

图3-39 Preferences对话框
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图3-39所示为General→Appearance设置页面,在这个页面上可以选择软件的界面主

题(Theme)、颜色和字体主题(Color
 

and
 

font
 

theme)。单击Apply按钮,可立刻应用所设

置的选项;
 

单击Restore
 

Defaults按钮可以恢复为默认值。

General→Appearance→Color
 

and
 

Fonts用于设置各种类型文字的字体,如C语言程序

文件、各种视图界面的字体。颜色和字体设置的操作比较直观和简单,用户自己尝试操作即

可,设置页面上都有Restore
 

Defaults按钮,可以恢复默认值。
调整编辑器文字的字体大小,可以通过快捷键操作,按住Ctrl键和加号键(+)可以放

大字体,按住Ctrl键和减号键(-)可以缩小字体。

2.
 

代码追踪和导航

在编辑器中,当鼠标悬停在某个类型、变量、函数名称等元素上时,会出现一个悬浮框,
显示该元素定义的源代码,如图3-40所示。按F2键或单击此悬浮框,就会弹出为一个具有

滚动条的窗口,可以查看完整的代码。这个功能有助于就地查看某个类型、变量、函数等元

素的定义,如图3-41所示。

图3-40 元素定义的就地显示(悬浮框)

图3-41 元素定义的就地显示(具有滚动条的窗口)
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若要跳转到某个类型、变量、函数名称等元素定义的源代码处,只需将鼠标悬停在这个

元素上并按F3键,其程序文件就会打开并定位到定义的代码处。

图3-42 鼠标悬停在 MX_NVIC_Init()函数

使用F3键可以在程序文件的函数原型定

义和源代码文件的函数代码之间实现跳转。例

如,将鼠标悬停在main.c文件中的 MX_NVIC_

Init()函数的原型定义处(见图3-42),按F3键

就会跳转到main.c文件中此函数的实现代码处

(见图3-43)。
若只是要在头文件(.h)和程序文件(.c)之间切换,可以使用Ctrl+Tab快捷键。
要在一个文件中快速定位到某个元素,使用Outline视图是最方便的,如图3-44所示。

Outline视图列出了当前编辑文件中的变量、类型、函数等元素,在Outline视图中单击这个

元素就能在编辑器中定位到这个元素。

图3-43 跳转到 MX_NVIC_Init()函数的实现代码
    

图3-44 Outline
 

视图

3.
 

编辑功能快捷操作

编辑器的一些有用的快捷操作总结如表3-2所示。这些快捷操作在编辑器的快捷菜单

或Edit和Source主菜单的下拉菜单里可以找到。注意,表3-2中没有最常用的撤销、剪切、
复制等编辑操作。

表3-2 编辑器的快捷操作

操  作 快 捷 键 功
 

能
 

说
 

明

Toggle
 

Comment Ctrl+7或Ctrl+/ 在选中的文本行前面加//使其变为注释,或解除注释

Add
 

Block
 

Comment Ctrl+Shift+/ 将选中的代码用/*
 

*/进行块注释

Remove
 

Block
 

Comment Ctrl+Shift+\ 移除块注释的注释符号

Shift
 

Left Shift+Tab 将选中的代码行向左移动,减少缩进

Correct
 

Indentation Ctrl+I 自动修正选中代码行的缩进格式

Format Ctrl+Shift+F 自动调整所选行的格式

Toggle
 

Source/Header Ctrl+Tab 在源代码文件和头文件之间切换

Toogle
 

Breakpoint Ctrl+Shift+B 在当前行设置或取消断点
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3.4 STM32CubeIDE项目的文件组成

图3-45 Project
 

Explorer
 

视图中项目

LED的文件夹和文件

本节将介绍STM32CubeIDE项目的文件组成。

STM32CubeIDE的一个项目就是一个文件夹,项
目名称就是文件夹的名称。如图3-45所示,除了根目

录下的LED.ioc是STM32CubeMX的文件,其他都是

STM32CubeIDE项目的文件夹和文件。

STM32CubeIDE项目中包含所选型号 MCU必要

的驱 动 程 序,包 括 CMSIS(Cortex
 

Microcontroller
 

Software
 

Interface
 

Standard)驱动程序和HAL驱动程

序,还有用户应用相关的程序文件。这些驱动程序是

STM32CubeMX根据 MCU的配置自动从安装的嵌入

式软件库中复制过来的,用户应用程序包括所用外设

的初始化程序。
图3-45 所 示 为 Project

 

Explorer视 图 中 项 目

LED的文件夹和文件,这个视图显示的就是该项目目

录下 的 所 有 文 件 夹 和 文 件。该 项 目 选 用 的 MCU
是STM32F407ZG。

3.4.1 CMSIS驱动程序文件

\Drivers\CMSIS目录下是CMSIS的驱动程序,
包括Cortex内核的驱动程序和具体MCU器件的基础

定义头文件,它有两个子目录。
(1)

 

\Drivers\CMSIS\DeviceST\STM32F4xx\
Include目录:

 

这个目录下是具体型号 MCU的相关定

义文件。

①
  

stm32f407xx.h:
 

这是CMSIS的STM32F407xx系列器件的外设访问头文件,其中

包含所有外设的地址映射和数据结构定义,以及外设寄存器的定义,用于访问外设寄存器的

宏定义等。

②
  

stm32f4xx.h:
 

这是STM32F4xx系列器件的配置文件,它根据项目的编译符号定

义,在条件编译中包含具体的MCU定义头文件(如stm32f407xx.h),这个文件中有如下代码段。

  #if
 

defined STM32F405xx 
  #include

 

"stm32f405xx h"
#elif

 

defined STM32F415xx 
  #include

 

"stm32f415xx h"
#elif

 

defined STM32F407xx 

第11集
微课视频
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  #include
 

"stm32f407xx h"
  

   本例用到的具体型号MCU
#elif

 

defined STM32F417xx 
  #include

 

"stm32f417xx h"

stm32f4xx.h文件中还有如下条件编译语句,用于确定是否包含 HAL驱动的基础头

文件stm32f4xx_hal.h。

  #if
 

defined
 

 USE_HAL_DRIVER 
  #include

 

"stm32f4xx_hal h"
#endif

  

 *
 

USE_HAL_DRIVER
 

* 

stm32f4xx.h文件中用到的条件编译符号STM32F407xx和 USE_HAL_DRIVER是

在项目的编译设置中定义的。执行Project→Properties菜单命令,弹出项目属性设置

Properties
 

for
 

LED对话框,在C/C++ Build→Settings节点的 Tool
 

Settings页面,单击

MCU
 

GCC
 

Compiler→Preprocessor,就可以看到这两个预处理符号,如图3-46所示。

图3-46 定义预处理符号
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③
 

system_stm32f4xx.h:
 

这个文件里定义了系统初始化函数SystemInit(),这个函数

是在系统复位之后,执行main()函数之前调用的。SystemInit()函数对SRAM的向量表重

定位,配置FSMC/FMC外设以使用外部的SRAM或SDRAM。
(2)

 

\Drivers\CMSIS\Include目录:
 

这个目录下都是与Cortex-M 内核相关的一些文

件(见图3-47),是Arm公司提供的定义文件,与具体的 MCU型号无关。

图3-47 Arm内核驱动文件

3.4.2 HAL驱动程序文件

STM32的硬件抽象层(HAL)驱动程序文件是一个官方提供的嵌入式软件库,旨在简

化STM32微控制器的开发。HAL驱动程序通过一组API函数封装底层硬件操作,提供对

微控制器外设(如GPIO、ADC、UART、SPI等)的抽象访问,这使得开发者无须深入了解硬

件细节即可控制和使用这些外设。此外,HAL还支持跨平台的代码移植,使得代码能够在

不同的STM32设备上复用,提高开发效率和代码可维护性。

1.
 

外设驱动程序

\Drivers\STM32F4xx_HAL_Driver目录下是STM32F4xx系列器件的 HAL驱动程

序。该目录下有两个子目录:
 

\Inc目录和\Src目录。\Inc目录(见图3-48)下是头文件,

\Src目录下是程序文件。一个头文件对应一个程序文件,分别保存在这两个目录下。每种

外设有一个基本驱动文件,有的还有一个扩展驱动文件。

stm32f4xx_hal_ppp.h是外设ppp的基本驱动程序头文件,如 GPIO的驱动头文件
 

stm32f4xx_hal_gpio.h、定时器的驱动头文件stm32f4xx_hal_tim.h等。

stm32f4xx_hal_ppp_ex.h是外设ppp的扩展驱动程序头文件,包括某个型号或某个系

列 MCU的特定 API函数,或重新定义的用于替换基本驱动程序的一些 API函数,如
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图3-48 HAL
 

驱动文件

stm32f4xx_hal_gpio_ex.h、stm32f4xxx_hal_tim_ex.h等。

\Drivers\STM32F4xx_HAL_Driver目录下除了外设的驱动程序文件,还有HAL库的

几个基础文件。

2.
 

HAL驱动头文件stm32f4xx_hal.h
stm32f4xx_hal.h文件中有HAL驱动的一些宏定义和函数定义。最主要的一个函数

是HAL_Init(),用于HAL库的初始化,其功能是复位所有外设、初始化Flash接口、配置

系统定时器SysTick周期为1ms。main()函数里首先执行的就是 HAL_Init()函数,代码

如下。

  HAL_StatusTypeDef
 

HAL_Init
 

 void 
 
   *配置

 

Flash
 

Prefetch 
 

Instruction
 

Cache 
 

Data
 

Cache* 
  #if

 

 INSTRUCTION_CACHE_ENABLE
 

 =
 

0U 
  _HAL_FLASH_INSTRUCTION_CACHE_ENABLE   
  #endif

 

 *
 

INSTRUCTION_CACHE_ENABLE
 

* 
  #if

 

 DATA_CACHE_ENABLE
 

 =0U 
  HAL_FLASH_DATA_CACHE_ENABLE   
  #endif

 

 *
 

DATA_CACHE_ENABLE
 

* 
  #if

 

 PREFETCH_ENABLE
 

 =
 

0U 
  _HAL_FLASH_PREFETCH_BUFFER_ENABLE   
  #endif

 

 *
 

PREFETCH_ENABLE
 

* 
   *设置中断优先级分组策略* 
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  HAL_NVIC_SetPriorityGrouping
 

 NVIC_PRIORITYGROUP_4  
   *使用SysTick作为基础时钟 配置SysTick定时周期为1ms* 
  HAL_InitTick TICK_INT_PRIORITY  
   *初始化底层硬件 与MCU相关* 
  HAL_MspInit   
  return

 

HAL_OK 
 

HAL_Init()函数中调用的两个函数 HAL_InitTick()和 HAL_MspInit()都是用

__weak修饰符定义的。例如,stm32f4xx_hal.c文件中 HAL_MspInit()函数的代码如下

(保留了英文注释)。

  __weak
 

void
 

HAL_MspInit
 

 void 
 
   *

 

NOTE
 

 
 

This
 

function
 

should
 

not
 

be
 

modified 
 

when
 

the
 

callback
 

is
 

needed the
 

HAL_MspInit
 

could
 

be
 

implemented
 

in
 

the
 

user
 

file
  注意 这个函数不应该被修改 需要调用时 可以在用户文件里重新实现HAL_MspInit  函数
  * 
 

函数前面使用__weak修饰符,这种函数称为“弱函数”。这个弱函数里没有任何代码,
注释表明,如果用户需要在HAL初始化时做一些针对 MCU的初始化操作,可以在自己的

程序文件里重新定义这个函数。之后,在项目编译时,编译的就是用户重新实现的 HAL_

MspInit()函数,而不是 HAL库中的弱函数 HAL_MspInit()。在 HAL库中有大量的弱

函数。

stm32f4xx_hal.h文件还声明了一个常用的延时函数 HAL_Delay(),它基于系统定时

器SysTick实现精确的毫秒级延时。

3.
 

HAL通用定义文件stm32f4xx_hal_def.h
stm32f4xx_hal_def.h文件中有 HAL的一些通用定义,包括枚举类型、宏定义、结构体

等。例如,HAL库中很多函数的返回值类型HAL_StatusTypeDef,就是在这个文件里定义

的一个枚举类型,定义如下。

  typedef
 

enum
 
  HAL_OK    =0x00U 
  HAL_ERROR

       

=0x01U 
  HAL_BUSY

          

=0x02U 
  HAL_TIMEOUT

      

=0x03U
 

 

HAL_StatusTypeDef 

4.
  

Cortex
 

HAL驱动文件
 

stm32f4xx
 

_hal_cortex.h
stm32f4xx_hal_cortex.h文件是Cortex

 

HAL
 

驱动文件,它提供 HAL驱动中用到的

Cortex内核的一些常量、结构体和函数定义,如中断优先级定义、中断优先级设置函数等。

\Drivers目录下的驱动程序文件都来自STM32CubeF4固件库。在STM32CubeMX
里,生成STM32CubeIDE项目代码时,系统会自动根据 MCU型号和用到的外设将需要的

驱动程序文件复制到STM32CubeIDE项目中,并组织好目录结构。\Drivers目录下的文件
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都不要修改,只有极少数情况下需要修改,但是修改后如果用STM32CubeMX再次生成代

码,所做的修改会丢失。

3.4.3 用户程序文件

用户程序文件架构如图3-49所示,在STM32CubeMX里设置导出代码选项时,选择生

图3-49 用户程序文件架构

成.c/.h文件对。

1.
 

外设的初始化程序文件

在生成代码时,STM32CubeMX会为启用的外设都生成

一个外设初始化程序文件。例如,在本项目中,使用PF9和

PF10引脚作为输出引脚驱动两个LED,就用到了GPIO外

设,所以生成了 GPIO 初始化程序文件gpio.c和gpio.h。

gpio.h文件定义了GPIO外设初始化函数原型。

  void
 

MX_GPIO_Init void  

在gpio.c文件中,有 MX_GPIO_Init()函数的实现代

码,对用到的两个 GPIO 引脚进行了初始化设置。MX_

GPIO_Init()函数的实现代码如下。

  void
 

MX_GPIO_Init void 
 
  GPIO_InitTypeDef

 

GPIO_InitStruct= 0  
   *GPIO

 

端口和时钟使能* 
  HAL_RCC_GPIOF_CLK_ENABLE   
  HAL_RCC_GPIOH_CLK_ENABLE   
  HAL_RCC_GPIOA_CLK_ENABLE   
   *配置

 

GPIO
 

引脚输出电平 输出* 
  HAL_GPIO_WritePin

 

 LED1_GPIO_Port 
 

LED1_Pin 
 

GPIO_PIN_SET  
   *配置

 

GPIO
 

引脚输出电平 输出* 
  HAL_GPIO_WritePin LED2_GPIO_Port 

 

LED2_Pin 
 

GPIO_PIN_RESET  
   *配置

 

GPIO
 

引脚 LED1_Pin
 

和LED2_Pin
 

在main h中定义* 
  GPIO_InitStruct Pin

 

=
 

LED1_Pin|LED2_Pin 
  GPIO_InitStruct Mode

 

=
 

GPIO_MODE_OUTPUT_PP 
  GPIO_InitStruct Pull

 

=
 

GPIO_NOPULL 
  GPIO_InitStruct Speed=

 

GPIO_SPEED_FREQ_LOW 
  HAL_GPIO_Init GPIOF &GPIO_InitStruct  
 

2.
 

HAL配置文件
 

stm32f4xx_hal_conf.h
stm32f4xx_hal_conf.h文件是对 HAL驱动程序的一些配置,如启用 MCU上的哪些

外设模块,对RCC的 HSE、HSI、LSE、LSI等时钟频率的设置等。该文件中的部分代码

如下。

   *********模块选择********* 
#define

 

HAL_MODULE_ENABLED
  #define

 

HAL_ADC_MODULE_ENABLED
  #define

 

HAL_CAN_MODULE_ENABLED
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  #define
 

HAL_LPTIM_MODULE_ENABLED
  #define

 

HAL_EXTI_MODULE_ENABLED
#define

 

HAL_GPIO_MODULE_ENABLED
#define

 

HAL_EXTI_MODULE_ENABLED
#define

 

HAL_DMA_MODULE_ENABLED
#define

 

HAL_RCC_MODULE_ENABLED
#define

 

HAL_FLASH_MODULE_ENABLED
#define

 

HAL_PWR_MODULE_ENABLED
#define

 

HAL_CORTEX_MODULE_ENABLED
 ***********HSE HSI

 

频率设置************* 
#if

 

 defined
 

 HSE_VALUE 
#define

 

HSE_VALUE    uint32_t 8000000U    *HSE晶振频率 单位为Hz* 
#endif

 

 *
 

HSE_VALUE
 

* 

代码段中的模块选择部分未显示完整代码,注释掉了未使用模块的定义语句。代码段

中定义了宏HSE_VALUE为8000000,也就是在STM32CubeMX的时钟树中设置HSE晶

振频率为8MHz。

stm32f4xxhalconf.h文件的内容是根据STM32CubeMX中的配置自动生成的,一般不

要直接修改此文件,而是在STM32CubeMX里修改配置后重新生成代码。

3.
 

中断服务例程文件

stm32f4xx_it.h文件中是中断服务例程(Interrupt
 

Service
 

Routine,ISR)的定义,

stm32f4xx_it.c文件中是ISR的实现代码。stm32f4xx_it.h文件中的一些函数原型定义

如下。

   ****导出的函数原型**** 
void

 

NMI_Handler void  
void

 

HardFault_Handler void  
void

 

MemManage_Handler
 

 void  
void

 

BusFault_Handler void  
void

 

UsageFault_Handler void  
void

 

SVC_Handler void  
void

 

DebugMon_Handler void  
void

 

PendSV_Handler void  
void

 

SysTick_Handler void  
 *

 

USER
 

CODE
 

BEGIN
 

EFP
 

* 
 *

 

USER
 

CODE
 

END
 

EFP
 

* 

本项目的功能是简单地用GPIO引脚驱动LED,并没有显式地使用中断,但是文件里

已经定义了一些ISR。这些是系统用到的一些中断的ISR,它们的函数实现代码里一般没

有做什么处理,只有SysTick_Handler()函数有实现代码。

SysTick_Handler()是系统定时器SysTick的ISR,系统定时器SysTick每1ms中断一

次,产生周期为1ms的嘀嗒信号。HAL使用它实现毫秒级精确延时函数HAL_Delay()。
各种中断的ISR名称是固定的,startup_stm32f407zgtx.s文件中定义了这些ISR名

称。使用STM32Cube开发方式时,我们可以在STM32CubeMX里图形化地设置和管理所

有中断,生成代码时,会自动在stm32f4xx_it.h和stm32f4xx_it.c文件中生成已开启中断

的ISR声明和代码框架,用户一般不需要直接修改stm32f4xx_it.h和stm32f4xx_it.c文件
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的内容。

4.
 

HAL的 MSP初始化程序文件

stm32f4xx_hal_msp.c是 HAL库的 MSP程序文件。MSP是 MCU
 

Specific
 

Package
的缩写,即 MCU特定程序包。这个文件定义了 HAL库的 MSP初始化函数和反初始化

(Deinitialization)函数。本项目的这个文件里有 MSP初始化函数 HAL_MspInit(),代码

如下。

  void
 

HAL_MspInit void 
 
   *

 

USER
 

CODE
 

BEGIN
 

MspInit
 

0
 

* 
   *

 

USER
 

CODE
 

END
 

MspInit
 

0
 

* 
  _HAL_RCC_SYSCFG_CLK_ENABLE   
  _HAL_RCC_PWR_CLK_ENABLE   
   *

 

System
 

interrupt
 

init* 
   *

 

USER
 

CODE
 

BEGIN
 

MspInit
 

1
 

* 
   *

 

USER
 

CODE
 

END
 

MspInit
 

1
 

* 
 

HAL_MspInit()函数的功能是针对具体MCU做一些初始化工作。这个函数实际上是

对stm32f4xx_hal.c文件中用__weak修饰符定义的弱函数 HAL_MspInit()的重新实现。
在主程序里调用HAL初始化函数HAL_Init()时,实际就是调用了在这个文件中重新实现

的HAL_MspInit()函数。

5.
 

处理器系统初始化文件system_stm32f4xx.c
system_stm32f4xx.c文件是\Drivers\CMSIS\Device\ST\STM32F4xx\include目录

下的系统初始化定义头文件system_stm32f4xx.h的程序实现文件,主要实现了SystemInit()
和SystemCoreClockUpdate()两个函数。

SystemInit()函数在系统复位之后、main()函数执行之前执行,其功能是初始化FPU
设置、向量表重定位、外部存储器配置。这个文件的代码是由STM32CubeMX根据配置自

动生成的,不需要手动修改。

6.
 

最小系统调用文件

syscalls.c和sysmem.c文件是STM32CubeIDE最小系统需要用到的文件。syscalls.c
文件定义了一些底层函数,sysmem.c文件定义了内存管理函数。这两个文件里的函数是

被STM32CubeIDE调用的,用户程序不会直接用到。

7.
 

主程序文件

主程序文件就是main.h和main.c。main.h文件的完整代码如下。为使代码更容易

阅读,这里剔除了程序中的注释和条件编译不成立的部分。

   *文件 main h
 

* 
 *

 

Includes
 

----------------------------------* 
#include

 

"stm32f4xx_hal h"
 *

 

Exported
 

functions
 

prototypes
 

----------------------* 
void

 

Error_Handler void  
 *

 

Private
 

defines
 

--------------------------------* 
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#define
 

LED1_RED_Pin
 

GPIO_PIN_6
#define

 

LED1_RED_GPIO_Port
 

GPIOF
#define

 

LED2_GREEN_Pin
 

GPIO_PIN_7
#define

 

LED2_GREEN_GPIO_Port
 

GPIOF
#define

 

LED3_BLUE_Pin
 

GPIO_PIN_8
#define

 

LED3_BLUE_GPIO_Port
 

GPIOF

main.h文件定义了几个宏,这是因为在STM32CubeMX中设置了PF6引脚的用户标

签为LED1,PF7引脚的用户标签为LED2,PF8引脚的用户标签为LED3。STM32CubeMX生

成代码时自动在main.h文件中为这些定义了用户标签的引脚创建宏定义。

main.c文件的完整代码如下。为使代码更容易阅读,这里剔除了程序中的注释和条件

编译不成立的部分,并且将部分关键注释译为中文。

   文件 main c
 

* 
#include

 

"main h"
#include

 

"gpio h"
 *

 

Private
 

includes
 

---------------------------------* 
 *

 

USER
 

CODE
 

BEGIN
 

Includes
 

* 
#include

 

"bsp_led h"
 *

 

USER
 

CODE
 

END
 

Includes
 

* 
 *

 

私有函数原型* 
void

 

SystemClock_Config void  
int

 

main void 
 
   *

 

MCU
 

Configuration--------------------------------* 
  HAL_Init   

 

  HAL初始化 包括MCU
 

配置 复位所有外设 初始化Flash接口和SysTick
  SystemClock_Config   

 

          系统时钟配置
  MX_GPIO_Init   

 

  GPIO
 

初始化
   *

 

USER
 

CODE
 

BEGIN
 

2
 

* 
   *

 

LED
 

端口初始化
 

* 
  LED_GPIO_Config   
   *

 

USER
 

CODE
 

END
 

2
 

* 
   *

 

Infinite
 

loop
 

* 
   *

 

USER
 

CODE
 

BEGIN
 

WHILE
 

* 
  while

 

 1 
   
    LED1 

 

ON
 

  
  

  亮
 

    HAL_Delay 1000  
    LED1 

 

OFF
 

  
  

  灭
    HAL_Delay 1000  

    LED2 
 

ON
 

  
  

  亮
 

    HAL_Delay 1000  
    LED2 

 

OFF
 

  
  

  灭

    LED3 
 

ON
 

  
 

  亮
 

    HAL_Delay 1000  
    LED3 

 

OFF
 

  
  

  灭

     *轮流显示
 

红绿蓝黄紫青白
 

颜色* 
    LED_RED 
    HAL_Delay 1000  
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    LED_GREEN 
    HAL_Delay 1000  

    LED_BLUE 
    HAL_Delay 1000  

    LED_YELLOW 
    HAL_Delay 1000  

    LED_PURPLE 
    HAL_Delay 1000  

    LED_CYAN 
    HAL_Delay 1000  

    LED_WHITE 
    HAL_Delay 1000  

    LED_RGBOFF 
    HAL_Delay 1000  
     *

 

USER
 

CODE
 

END
 

WHILE
 

* 

     *
 

USER
 

CODE
 

BEGIN
 

3
 

* 
   
   *

 

USER
 

CODE
 

END
 

3
 

* 
 

void
 

SystemClock_Config void 
 
  RCC_OscInitTypeDef

 

RCC_OscInitStruct
 

=
 

 0  
  RCC_ClkInitTypeDef

 

RCC_ClkInitStruct
 

=
 

 0  

   *配置主要内部调节器的输出电压* 
  __HAL_RCC_PWR_CLK_ENABLE   
  __HAL_PWR_VOLTAGESCALING_CONFIG PWR_REGULATOR_VOLTAGE_SCALE1  

   *根据RCC_OscInitTypeDef结构中指定的参数初始化RCC振荡器
 

* 
  RCC_OscInitStruct OscillatorType

 

=
 

RCC_OSCILLATORTYPEHSE 
    

    使用
 

HSE
  RCC_OscInitStruct HSEState

 

=
 

RCC_HSE_ON 
  

  开启HSE
  RCC_OscInitStruct PLL PLLState

 

=
 

RCC_PLL_ON 
  

  启动主锁相环
  RCC_OscInitStruct PLL PLLSource=

 

RCC_PLLSOURCE_HSE 
 

  PLL时钟源设置为HSE
  RCC_OscInitStruct PLL PLLM=25 

  

  PLLM分频器系数=25
  RCC_OscInitStruct PLL PLLN=336 

  

  PLLN倍频器系数=336
  RCC_OscInitStruct PLL PLLP

 

=
 

RCC_PLLP_DIV2 
 

  PLLP分频器系数=2
  RCC_OscInitStruct PLL PLLQ

 

=
 

4 
 

  LLQ分频器系数=4
  if

 

 HAL_RCC_OscConfig &RCC_OscInitStruct 
 

 =
 

HAL_OK 
   
    Error_Handler   
   

   *
 

Initializes
 

the
 

CPU 
 

AHB
 

and
 

APB
 

buses
 

clocks
 

* 
  RCC_ClkInitStruct ClockType

 

=
 

RCC_CLOCKTYPE_HCLK|RCC_CLOCKTYPE_SYSCLK
|RCC_CLOCKTYPE_PCLK1|RCC_CLOCKTYPE_PCLK2 

  RCC_ClkInitStruct SYSCLKSource
 

=
 

RCC_SYSCLKSOURCE_PLLCLK 



117  

  RCC_ClkInitStruct AHBCLKDivider
 

=
 

RCC_SYSCLK_DIV1 
  RCC_ClkInitStruct APB1CLKDivider

 

=
 

RCC_HCLK_DIV4 
  RCC_ClkInitStruct APB2CLKDivider

 

=
 

RCC_HCLK_DIV2 

  if
 

 HAL_RCC_ClockConfig &RCC_ClkInitStruct 
 

FLASH_LATENCY_5 
 

 =
 

HAL_OK 
   
    Error_Handler   
   
 

 **
 *

 

@brief
  

This
 

function
 

is
 

executed
 

in
 

case
 

of
 

error
 

occurrence 
 *

 

@retval
 

None
 *错误处理函数* 
void

 

Error_Handler void 
 
   *

 

用户代码开始错误处理调试
 

* 
   *

 

用户可以添加自己的代码报告HAL错误返回状态
 

* 
  __disable_irq   
  while

 

 1 
   
   
   *

 

USER
 

CODE
 

END
 

Error_Handler_Debug
 

* 
 

main.c文件定义了一个SystemClock_Config()函数,用于系统时钟配置,包括CPU、

AHB和APB总线时钟频率的定义。这个函数的代码是根据STM32CubeMX里RCC和时

钟树的设置自动生成的。因此,若需要修改某个时钟信号频率,应该在STM32CubeMX里

修改时钟树后重新生成代码。
再看主函数main()的代码功能,它依次调用了以下3个函数,然后进入while循环。
(1)

 

HAL_Init(),这是在stm32f4xx_hal.h文件中定义的HAL库初始化函数。HAL_

Init()函数又调用了重新实现的 MSP函数HAL_MspInit(),用于特定 MCU的初始化。
(2)

 

SystemClock_Config(),这是在 main.c文件中定义的函数,用于对系统时钟进行

配置。
(3)

 

MX_GPIO_Init(),这是 GPIO外设的初始化函数,也就是对3个LED引脚的

GPIO初始化,定义在gpio.h文件中。
在STM32CubeIDE文本编辑器中,因为条件编译的条件不成立而不会被编译的代码

会以灰色底色显示,这样容易看出条件编译的影响代码范围。

3.4.4 启动文件

\startup目录下的startup_stm32f407zgtx.s文件是处理器的启动文件,这是一个汇编

语言程序文件,是 MCU复位后首先执行的程序。启动文件的作用是初始化堆栈指针SP和

代码指针
 

PC,设置中断程序向量表,执行system_stm32f4xx.c文件中的SystemInit()函
数,然后执行主函数main()。
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所有中断的ISR名称都在startup_stm32f407zgtx.s文件中定义。例如,下面是系统中

断和部分可屏蔽中断ISR名称的定义。

  g_pfnVectors 
 word  _estack
 word

  

Reset_Handler
 word NMI_Handler
 word HardFault_Handler
 word MemManage_Handler
 word BusFault_Handler
 word UsageFault_Handler
 word 0
 word 0
 word 0
 word 0
 word SVC_Handler
 word DebugMon_Handler
 word 0
 word PendSV_Handler
 word SysTick_Handler

 *
 

External
 

Interrupts
 

* 
 word  WWDG_IRQHandler         *

 

Window
 

WatchDog
 

* 
                                        

 word
     

PVD_IRQHandler
            

 *
 

PVD
 

through
 

EXTI
 

Line
 

detection
 

* 
                        

 word
     

TAMP_STAMP_IRQHandler
   

 *
 

Tamper
 

and
 

TimeStamps
 

through
 

the
 

EXTI
 

line
 

* 
            

 word
     

RTC_WKUP_IRQHandler
     

 *
 

RTC
 

Wakeup
 

through
 

the
 

EXTI
 

line
 

* 
                      

 word
     

FLASH_IRQHandler
         

 *
 

Flash
 

* 
                                          

 word
     

RCC_IRQHandler
           

 *
 

RCC
 

* 
                                            

 word
     

EXTI0_IRQHandler
          

 *
 

EXTI
 

Line0
 

* 
                        

 word
     

EXTI1_IRQHandler
          

 *
 

EXTI
 

Line1* 
                          

 word
     

EXTI2_IRQHandler
          

 *
 

EXTI
 

Line2* 
                          

 word
     

EXTI3_IRQHandler
          

 *
 

EXTI
 

Line3* 
                          

 word
     

EXTI4_IRQHandler
          

 *
 

EXTI
 

Line4* 
                          

 word
     

DMA1_Stream0_IRQHandler
  

 *
 

DMA1
 

Stream
 

0* 
                  

 word
     

DMA1_Stream1_IRQHandler
  

 *
 

DMA1
 

Stream
 

1* 
                   

 word
     

DMA1_Stream2_IRQHandler
  

 *
 

DMA1
 

Stream
 

2* 
                   

 word
     

DMA1_Stream3_IRQHandler
   

 *
 

DMA1
 

Stream
 

3* 
                   

 word
     

DMA1_Stream4_IRQHandler
   

 *
 

DMA1
 

Stream
 

4* 
                   

 word
     

DMA1_Stream5_IRQHandler
   

 *
 

DMA1
 

Stream
 

5* 
                   

 word
     

DMA1_Stream6_IRQHandler
   

 *
 

DMA1
 

Stream
 

6* 
                   

 word
     

ADC_IRQHandler
            

 *
 

ADC1 
 

ADC2
 

and
 

ADC3s* 
                   

 word
     

CAN1_TX_IRQHandler
       

 *
 

CAN1
 

TX* 
                         

 word
     

CAN1_RX0_IRQHandler
      

 *
 

CAN1
 

RX0* 
                          

 word
     

CAN1_RX1_IRQHandler
      

 *
 

CAN1
 

RX1* 
                          

 word
     

CAN1_SCE_IRQHandler
               

 *
 

CAN1
 

SCE* 
                          

 word
     

EXTI9_5_IRQHandler
                  

 *
 

External
 

Line 9 5 s
 

* 
                          

 word
     

TIM1_BRK_TIM9_IRQHandler
          

 *
 

TIM1
 

Break
 

and
 

TIM9* 
         

 word
     

TIM1_UP_TIM10_IRQHandler
          

 *
 

TIM1
 

Update
 

and
 

TIM10* 
         

 word
     

TIM1_TRG_COM_TIM11_IRQHandler
   

 *
 

TIM1
 

Trigger
 

and
 

Commutation
 

and
 

TIM11
 

* 
 word

     

TIM1_CC_IRQHandler
                

 *
 

TIM1
 

Capture
 

Compare* 
                          

 word
     

TIM2_IRQHandler
                    

 *
 

TIM2* 
                   

 word
     

TIM3_IRQHandler
                    

 *
 

TIM3* 
                   

 word
     

TIM4_IRQHandler
                   

 *
 

TIM4* 
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 word
     

I2C1_EV_IRQHandler
                

 *
 

I2C1
 

Event* 
                          

 word
     

I2C1_ER_IRQHandler
                

 *
 

I2C1
 

Error* 
                          

 word
     

I2C2_EV_IRQHandler
                

 *
 

I2C2
 

Event* 
                          

 word
     

I2C2_ER_IRQHandler
                

 *
 

I2C2
 

Error* 
                            

 word
     

SPI1_IRQHandler
                   

 *
 

SPI1* 
                   

 word
     

SPI2_IRQHandler
                   

 *
 

SPI2* 
                   

 word
     

USART1_IRQHandler
                 

 *
 

USART1* 
                   

 word
     

USART2_IRQHandler
                 

 *
 

USART2* 
                   

 word
     

USART3_IRQHandler
                 

 *
 

USART3* 
                   

 word
     

EXTI15_10_IRQHandler
              

 *
 

External
 

Line 15 10 s* 
                          

 word
     

RTC_Alarm_IRQHandler
              

 *
 

RTC
 

Alarm
 

 A
 

and
 

B 
 

through
 

EXTI
 

Line
 

* 
                 

 word
     

OTG_FS_WKUP_IRQHandler
          

 *
 

USB
 

OTG
 

FS
 

Wakeup
 

through
 

EXTI
 

line
 

* 
                       

 word
     

TIM8_BRK_TIM12_IRQHandler
         

 *
 

TIM8
 

Break
 

and
 

TIM12* 
         

 word
     

TIM8_UP_TIM13_IRQHandler
          

 *
 

TIM8
 

Update
 

and
 

TIM13* 
         

 word
     

TIM8_TRG_COM_TIM14_IRQHandler
   

 *
 

TIM8
 

Trigger
 

and
 

Commutation
 

and
 

TIM14
 

* 
 word

     

TIM8_CC_IRQHandler
                

 *
 

TIM8
 

Capture
 

Compare* 
                          

在stm32f4xx_it.h和stm32f4xx_it.c文件中定义和实现ISR 时,函数名必须与

startup_stm32f407zgtx.s文件中定义的函数名一致。

3.4.5 根目录下的文件

项目根目录下还有两个扩展名为.ld的文件,这两个文件是存储器的编译链接脚本文件。

STM32F407ZGTX_FLASH.ld文件用于设置堆的大小、栈的大小和位置、默认的各种

程序段和数据段的地址和长度等。如果使用了外部存储器,还要设置存储器的位置和大小。

STM32F407ZGTX_RAM.ld文件的功能基本相同,但只是在RAM中调试时才用。
这两个文件是根据STM32CubeMX中最小堆栈大小的设置,以及 MCU内部存储空间

的分布自动分配而生成的,是比较底层的内容,一般不需详细了解。
如果项目用仿真器下载到开发板上成功调试过,还会在根目录下生成一个扩展名为

.launch的文件,如LED
 

Debug.launch,这个文件保存了仿真调试器的启动配置参数。

3.4.6 Include搜索路径
 

在Project
 

Explorer的项目节点下,有一个虚拟的文件夹\Includes,这个文件夹不是硬

盘上项目里的实际文件夹,而是项目的Include搜索路径。图3-50所示为LED项目虚拟目

录\Includes下的内容,前4条是STM32CubeIDE的编译工具链标准库的路径,后5条是

LED项目的Include搜索路径。

图3-50 虚拟目录\Includes
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3.5 STM32CubeIDE菜单

STM32CubeIDE菜单设计合理,提供丰富功能以提升开发效率。File(文件)菜单涵盖

新建、打开、保存、导入、导出等文件和项目管理操作。Edit(编辑)菜单提供剪切、复制、粘
贴、查找、替换、撤销、重做等编辑功能,提高代码编辑效率。Source(源)菜单包含注释、代码

格式化、自动生成代码等工具,便于源代码管理。Refactor(重构)菜单支持代码重命名、提
取方法等重构操作,有助于优化代码结构。Navigate(导航)菜单提供快速定位代码、浏览资

源、高效导航功能。Search(搜索)菜单允许全局和特定搜索,提升查找效率。Project(项目)
菜单支持项目管理和配置,帮助用户高效构建和维护项目。Run(运行)菜单包含启动、调
试、断点管理等功能,便于控制程序执行。Window(窗口)菜单允许管理IDE布局、视图和

透视图。Help(帮助)菜单提供丰富的帮助资源和更新支持,确保获取最新信息和技术支

持。整体菜单设计提升了开发、调试和项目管理的效率,为开发者提供一个强大的开发环境。

3.5.1 File(文件)菜单

STM32CubeIDE的File(文件)菜单提供了一系列操作选项,方便用户进行文件和项目

管理。主要功能包括新建、打开文件和项目、查看最新文件、关闭单个或所有编辑器、保存和

另存为、撤销操作、文件移动及重命名、刷新、行分隔符转换(支持Windows和UNIX格式)、
打印、导入、导出、查看属性和切换工作区;

 

此外,还提供了重新启动和退出软件的选项。

图3-51 File菜单

File菜单如图3-51所示。

File菜单功能说明如下。
(1)

 

New:
 

新建。
(2)

 

Open
 

File:
 

打开文件。
(3)

 

Open
 

Projects
 

from
 

File
 

System:
 

从文件系

统打开项目。
(4)

 

Recent
 

Files:
 

最近文件。
(5)

 

Close
 

Editor:
 

关闭编辑器。
(6)

 

Close
 

All
 

Editors:
 

关闭所有编辑器。
(7)

 

Save:
 

保存。
(8)

 

Save
 

As:
 

另存为。
(9)

 

Save
 

All:
 

保存所有。
(10)

 

Revert:
 

撤销。
(11)

 

Move:
 

移动。
(12)

 

Rename:
 

重命名。
(13)

 

Refresh:
 

刷新。
(14)

 

Convert
 

Line
 

Delimiters
 

To:
 

转换行分隔符,子菜单如图3-52所示。
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图3-52 File→Convert
 

Line
 

Delimiters
 

To子菜单

(15)
 

Print:
 

打印。
(16)

 

Import:
 

导入。
(17)

 

Export:
 

导出。
(18)

 

Properties:
 

属性。
(19)

 

Switch
 

Workspace:
 

切换工作区,子菜单如图3-53所示。

图3-53 File→Switch
 

Workspace子菜单

(20)
 

Restart:
 

重新启动。
(21)

 

Exit:
 

退出。

3.5.2 Edit(编辑)菜单

STM32CubeIDE的Edit(编辑)菜单提供多种编辑功能以提升代码编辑效率。主要功

能包括撤销与重做、剪切、复制、粘贴、删除、全选、扩展选择至特定元素、多选、查找与替换、
单词与增量查找、添加书签与任务、智能插入模式、显示工具提示描述、单词自动补全、快速

修复、内容辅助和参数提示等;
 

此外,还提供了设置文本编码的选项。

图3-54 Edit菜单

Edit菜单如图3-54所示。

Edit菜单功能说明如下。
(1)

 

Undo:
 

撤销。
(2)

 

Redo:
 

重做。
(3)

 

Cut:
 

剪切。
(4)

 

Copy:
 

复制。
(5)

 

Paste:
 

粘贴。
(6)

 

Delete:
 

删除。
(7)

 

Select
 

All:
 

全选。
(8)

 

Expand
 

Selection
 

To:
 

扩展选择,子菜单如

图3-55所示。

①
 

Enclosing
 

Element:
 

包围元素。

②
 

Next
 

Element:
 

下一个元素。

③
 

Previous
 

Element:
 

上一个元素。

④
 

Restore
 

Last
 

Selection:
 

恢复上次选择。
(9)

 

To
 

multi-selection:
 

到多选。
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图3-55 Edit→Expand
 

Selection
 

To子菜单

(10)
 

Find/Replace:
 

查找/替换。
(11)

 

Find
 

Word:
 

查找单词。
(12)

 

Find
 

Next:
 

查找下一个。
(13)

 

Find
 

Previous:
 

查找上一个。
(14)

 

Incremental
 

Find
 

Next:
 

增量查找下一个。
(15)

 

Incremental
 

Find
 

Previous:
 

增量查找上一个。
(16)

 

Add
 

Bookmark:
 

添加书签。
(17)

 

Add
 

Task:
 

添加任务。
(18)

 

Smart
 

Insert
 

Mode:
 

智能插入模式。
(19)

 

Show
 

Tooltip
 

Description:
 

显示工具提示描述。
(20)

 

Word
 

Completion:
 

单词自动补全。
(21)

 

Quick
 

Fix:
 

快速修复。
(22)

 

Content
 

Assist:
 

内容辅助。
(23)

 

Parameter
 

Hints:
 

参数提示。
(24)

 

Set
 

Encoding:
 

设置编码。

3.5.3 Source(源)菜单

STM32CubeIDE的Source(源)菜单提供丰富的源代码管理功能。主要功能包括切换

注释、添加和移除块注释、代码行的左右移动、常量对齐、缩进校正、代码格式化、复制限定名

称、添加和组织包含文件、行排序、覆盖和实现方法、生成Getter和Setter方法;
 

此外,还提

图3-56 Source菜单

供包围选中内容的功能,支持配置模板。

Source菜单如图3-56所示。

Source菜单功能说明如下。
(1)

 

Toggle
 

Comment:
 

切换注释。
(2)

 

Add
 

Block
 

Comment:
 

添加块注释。
(3)

 

Remove
 

Block
 

Comment:
 

移除块注释。
(4)

 

Shift
 

Right:
 

向右移动。
(5)

 

Shift
 

Left:
 

向左移动。
(6)

 

Align
 

Const:
 

对齐常量。
(7)

 

Correct
 

Indentation:
 

校正缩进。
(8)

 

Format:
 

格式化。
(9)

 

Copy
 

Qualified
 

Name:
 

复制限定名称。
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(10)
 

Add
 

Include:
 

添加包含。
(11)

 

Organize
 

Includes:
 

组织包含。
(12)

 

Sort
 

Lines:
 

排序行。
(13)

 

Override
 

Methods:
 

覆盖方法。
(14)

 

Implement
 

Method:
 

实现方法。
(15)

 

Generate
 

Getters
 

and
 

Setters:
 

生成Getter和Setter方法。
(16)

 

Surround
 

With:
 

包围选中内容,子菜单如图3-57所示。

图3-57 Source→Surround
 

With子菜单

①
 

(no
 

template
 

applicable):
 

无适用模板。

②
 

Configure
 

Templates:
 

配置模板。

3.5.4 Refactor(重构)菜单

STM32CubeIDE的Refactor(重构)菜单提供多种代码重构功能,以帮助开发者优化代

码结构。主要功能包括重命名变量或方法、提取本地变量和常量、提取函数、切换函数显示、
隐藏方法、应用和创建脚本以及查看历史变更。这些工具有助于维护代码的可读性和可维

护性,提升开发人员在代码优化和重构过程中的效率。

图3-58 Refactor菜单

Refactor菜单如图3-58所示。

Refactor菜单功能说明如下。
(1)

 

Rename:
 

重命名。
(2)

 

Extract
 

Local
 

Variable:
 

提取本地变量。
(3)

 

Extract
 

Constant:
 

提取常量。
(4)

 

Extract
 

Function:
 

提取函数。
(5)

 

Toggle
 

Function:
 

切换函数显示。
(6)

 

Hide
 

Method:
 

隐藏方法。
(7)

 

Apply
 

Script:
 

应用脚本。
(8)

 

Create
 

Script:
 

创建脚本。
(9)

 

History:
 

历史。

3.5.5 Navigate(导航)菜单

STM32CubeIDE的Navigate(导航)菜单提供丰富的导航功能,帮助开发者高效浏览和

定位代码。主要功能包括进入特定目录、转至资源、上一级、匹配括号及书签等位置,还可以

打开声明、类型层次结构、调用层次结构和包含浏览器。此外,菜单支持切换源/头文件、快
速概要、前后导航及转至行等功能。Show

 

In子菜单允许在包含浏览器、项目管理器、问题
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详情等界面中显示选定资源。这些功能提升了代码浏览和编辑的便利性和效率。

图3-59 Navigate菜单

Navigate菜单如图3-59所示。

Navigate菜单功能说明如下。
(1)

 

Go
 

Into:
 

进入。
(2)

 

Go
 

To:
 

转至,子菜单如图3-60所示。

①
 

Back:
 

返回。

②
 

Forward:
 

前进。

③
 

Up
 

One
 

Level:
 

上一级。

④
 

Resource:
 

资源。

⑤
 

Next
 

Member:
 

下一个成员。

⑥
 

Previous
 

Member:
 

上一个成员。

⑦
 

Go
 

to
 

Matching
 

Bracket:
 

转到匹配括号。

⑧
 

Next
 

Bookmark:
 

下一个书签。
(3)

 

Open
 

Declaration:
 

打开声明。
(4)

 

Open
 

Type
 

Hierarchy:
 

打开类型层次结构。

图3-60 Navigate→Go
 

To子菜单

(5)
 

Open
 

Call
 

Hierarchy:
 

打开调用层次结构。
(6)

 

Open
 

Include
 

Browser:
 

打开包含浏览器。
(7)

 

Toggle
 

Source/Header:
 

切换源/头文件。
(8)

 

Open
 

Element:
 

打开元素。
(9)

 

Open
 

Type
 

in
 

Hierarchy:
 

在层次结构中打开类型。
(10)

 

Open
 

Element
 

in
 

Call
 

Hierarchy:
 

在调用层次结构中打开元素。
(11)

 

Open
 

Resource:
 

打开资源。
(12)

 

Show
 

In:
 

显示,子菜单如图3-61所示。

图3-61 Navigate→Show
 

In子菜单
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①
 

Include
 

Browser:
 

包含浏览器。

②
 

C/C++ Projects:
 

C/C++
 

项目。

③
 

Project
 

Explorer:
 

项目资源管理器。

④
 

Problem
 

Details:
 

问题详情。

⑤
 

Outline:
 

大纲。

⑥
 

System
 

Explorer:
 

系统资源管理器。

⑦
 

Properties:
 

属性。
(13)

 

Quick
 

Outline:
 

快速概要。
(14)

 

Next:
 

下一个。
(15)

 

Previous:
 

上一个。
(16)

 

Previous
 

Edit
 

Location:
 

上一个编辑位置。
(17)

 

Next
 

Edit
 

Location:
 

下一个编辑位置。
(18)

 

Go
 

to
 

Line:
 

转至某行。
(19)

 

Back:
 

返回。
(20)

 

Forward:
 

向前。

3.5.6 Search(搜索)菜单

STM32CubeIDE的Search(搜索)菜单提供多种导航和浏览功能,以便开发者高效的在

代码和项目中定位。主要功能包括进入特定部分、转至各种资源和代码结构、返回和前进、
导航至匹配括号和书签、打开声明和层次结构、切换源文件和头文件、显示在特定视图中、快
速概要、定位至编辑位置和行号等。通过这些功能,开发者可以快速在复杂项目中找到所需

的代码和资源,提升开发效率。

Search菜单如图3-62所示。

Search菜单功能说明如下。
(1)

 

Search:
 

搜索。
(2)

 

File:
 

文件。
(3)

 

C/C++:
 

搜索项目中的C/C++代码。
(4)

 

Text:
 

文本,子菜单如图3-63所示。

图3-62 Search菜单 图3-63 Search→Text子菜单

①
 

Workspace:
 

工作空间。

②
 

Project:
 

项目。
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③
 

File:
 

文件。
④

 

Working
 

Set:
 

工作集。
(5)

 

Quick
 

Search:
 

快速搜索。

3.5.7 Project(项目)菜单

STM32CubeIDE的Project(项目)菜单提供多种项目管理和构建功能,以便开发者高

效管理和编译项目。主要功能包括打开和关闭项目、构建全部或特定项目、配置和管理构建

设置、选择和管理工作集、清理项目、自动构建、设置构建目标、管理C/C++索引等。此外,
菜单还提供生成报告和代码、查看和编辑项目属性等功能。这些工具帮助开发者灵活控制

项目构建流程,提升生产力和项目管理效率。
Project菜单如图3-64所示。
Project菜单功能说明如下。
(1)

 

Open
 

Project:
 

打开项目。
(2)

 

Close
 

Project:
 

关闭项目。
(3)

 

Build
 

All:
 

构建全部。
(4)

 

Build
 

Configurations:
 

构建配置,子菜单如图3-65所示。

图3-64 Project菜单 图3-65 Project→Build
 

Configurations子菜单

①
 

Set
 

Active:
 

设置活动。
②

 

Manage:
 

管理。
③

 

Build
 

by
 

Working
 

Set:
 

按工作集构建。
④

 

Set
 

Active
 

by
 

Working
 

Set:
 

按工作集设置活动。
⑤

 

Manage
 

Working
 

Sets:
 

管理工作集。
(5)

 

Build
 

Project:
 

构建项目。
(6)

 

Build
 

Working
 

Set:
 

构建工作集,Select
 

Working
 

Set(选择工作集)子菜单如图3-66
所示。

(7)
 

Clean:
 

清理。
(8)

 

Build
 

Automatically:
 

自动构建。
(9)

 

Build
 

Targets:
 

构建目标,子菜单如图3-67所示。
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图3-66 Project→Build
 

Working
 

Set子菜单 图3-67 Project→Build
 

Targets子菜单

①
 

Create:
 

创建。

②
 

Build:
 

构建。

③
 

Rebuild
 

Last
 

Target:
 

重新构建上一个目标。
(10)

 

C/C++Index:
 

C/C++索引,子菜单如图3-68所示。

图3-68 Project→C/C++ Index子菜单

①
 

Rebuild:
 

重新构建。

②
 

Freshen
 

All
 

Files:
 

刷新所有文件。

③
 

Update
 

with
 

Modified
 

Files:
 

使用已修改的文件进行更新。

④
 

Re-resolve
 

Unresolved
 

Includes:
 

重新解析未解析的包含文件。

⑤
 

Search
 

for
 

Unresolved
 

Includes:
 

搜索未解析的包含文件。

⑥
 

Create
 

Parser
 

Log
 

File:
 

创建解析器日志文件。
(11)

 

Generate
 

Report:
 

生成报告。
(12)

 

Generate
 

Code:
 

生成代码。
(13)

 

Properties:
 

属性。

3.5.8 Run(运行)菜单

图3-69 Run菜单

STM32CubeIDE的Run(运行)菜单提供了一系列功

能,帮助开发者管理和执行项目的运行和调试。主要功能

包括运行、调试、查看运行和调试历史、配置运行和调试选

项、不同的断点类型(如C/C++断点和动态打印)和断点管

理(如切换、跳过和移除断点)。菜单还包含外部工具的运

行和配置选项,有助于扩展IDE功能。通过这些功能,开
发者可以方便地控制程序的执行流,优化调试和运行

效率。

Run菜单如图3-69所示。

Run菜单功能说明如下。
(1)

 

Run:
 

运行。
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(2)
 

Debug:
 

调试。
(3)

 

Run
 

History:
 

运行历史。
(4)

 

Run
 

As:
 

以…运行。
(5)

 

Run
 

Configurations:
 

运行配置。
(6)

 

Debug
 

History:
 

调试历史。
(7)

 

Debug
 

As:
 

以…调试。
(8)

 

Debug
 

Configurations:
 

调试配置。
(9)

 

Breakpoint
 

Types:
 

断点类型,子菜单如图3-70所示。

图3-70 Run→Breakpoint
 

Types子菜单

①
 

C/C++ Breakpoints:
 

C/C++断点。

②
 

C/C++ Dynamic
 

Printf:
 

C/C++动态打印。
(10)

 

Toggle
 

Breakpoint:
 

切换断点。
(11)

 

Toggle
 

Line
 

Breakpoint:
 

切换行断点。
(12)

 

Toggle
 

Watchpoint:
 

切换监视点。
(13)

 

Toggle
 

Method
 

Breakpoint:
 

切换方法断点。
(14)

 

Skip
 

All
 

Breakpoints
 

跳过所有断点。
(15)

 

Remove
 

All
 

Breakpoints:
 

移除所有断点。
(16)

 

External
 

Tools:
 

外部工具,子菜单如图3-71所示。

图3-71 Run→External
 

Tools子菜单

①
 

(no
 

launch
 

history):
 

没有启动历史。

②
 

Run
 

As:
 

以…方式运行。

③
 

External
 

Tools
 

Configurations:
 

外部工具配置。

④
 

Organize
 

Favorites:
 

组织收藏夹。

3.5.9 Window(窗口)菜单

STM32CubeIDE的 Window(窗口)菜单提供多种功能以管理视图和编辑器,包括新建

独立窗口、编辑器拆分与复制、自动换行、外观设置(如隐藏工具栏与状态栏)、显示不同视图

(如控制台和项目资源管理器)以及透视图管理(打开、定制、重置)。这些功能提升了用户的

工作效率和界面灵活性。
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Window菜单如图3-72所示。

Window菜单功能说明如下。
(1)

 

New
 

Window:
 

新建窗口。
(2)

 

Editor:
 

编辑器,子菜单如图3-73所示。

图3-72 Window菜单
  

图3-73 Window→Editor子菜单

①
 

Toggle
 

Split
 

Editor
 

(Horizontal):
 

切换拆分编辑器(水平)。

②
 

Toggle
 

Split
 

Editor
 

(Vertical):
 

切换拆分编辑器(垂直)。

③
 

Clone:
 

复制。

④
 

Toggle
 

Word
 

Wrap:
 

切换自动换行。

⑤
 

Show
 

Whitespace
 

Characters:
 

显示空白字符。

⑥
 

Zoom
 

In:
 

放大。

⑦
 

Zoom
 

Out:
 

缩小。
(3)

 

Appearance:
 

外观,子菜单如图3-74所示。

图3-74 Window→Appearance子菜单

①
 

Hide
 

Toolbar:
 

隐藏工具栏。

②
 

Hide
 

Status
 

Bar:
 

隐藏状态栏。

③
 

Toggle
 

Full
 

Screen:
 

切换全屏。

④
 

Maximize
 

Active
 

View
 

or
 

Editor:
 

最大化活动视图或编辑器。

⑤
 

Minimize
 

Active
 

View
 

or
 

Editor:
 

最小化活动视图或编辑器。
(4)

 

Show
 

View:
 

显示视图,子菜单如图3-75所示。

①
 

Build
 

Analyzer:
 

构建分析器。

②
 

Build
 

Targets:
 

构建目标。

③
 

C/C++ Projects:
 

C/C++
 

项目。

④
 

Console:
 

控制台。

⑤
 

Cyclomatic
 

Complexity:
 

圈复杂度。
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图3-75 Window→Show
 

View子菜单

⑥
 

Include
 

Browser:
 

头文件浏览器。

⑦
 

Outline:
 

大纲。

⑧
 

Problem
 

Details:
 

问题详情。

⑨
 

Problems:
 

问题。

⑩
 

Project
 

Explorer:
 

项目资源管理器。

􀃊􀁉􀁓
 

Properties:
 

属性。

􀃊􀁉􀁔
 

Search搜索。

􀃊􀁉􀁕
 

SFRs:
 

特殊功能寄存器。

􀃊􀁉􀁖
 

Static
 

Stack
 

Analyzer:
 

静态堆栈分析器。

􀃊􀁉􀁗
 

Tasks:
 

任务。

􀃊􀁉􀁘
 

Other:
 

其他。
(5)

 

Perspective:
 

透视,子菜单如图3-76所示。

图3-76 Window→Perspective子菜单

①
 

Open
 

Perspective:
 

打开透视图。

②
 

Customize
 

Perspective:
 

自定义透视图。

③
 

Save
 

Perspective
 

As:
 

另存透视图为。

④
 

Reset
 

Perspective:
 

重置透视图。

⑤
 

Close
 

Perspective:
 

关闭透视图。

⑥
 

Close
 

All
 

Perspectives:
 

关闭所有透视图。
(6)

 

Navigation:
 

导航,子菜单如图3-77所示。
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图3-77 Window→Navigation子菜单

①
 

Show
 

System
 

Menu:
 

显示系统菜单。

②
 

Show
 

View
 

Menu:
 

显示视图菜单。

③
 

Find
 

Actions:
 

查找操作。

④
 

Activate
 

Editor:
 

激活编辑器。

⑤
 

Next
 

Editor:
 

下一个编辑器。

⑥
 

Previous
 

Editor:
 

上一个编辑器。

⑦
 

Switch
 

to
 

Editor:
 

切换到编辑器。

⑧
 

Next
 

View:
 

下一个视图。

⑨
 

Previous
 

View:
 

上一个视图。

⑩
 

Next
 

Perspective:
 

下一个透视图。

􀃊􀁉􀁓
 

Previous
 

Perspective:
 

上一个透视图。
(7)

 

Preferences:
 

首选项。

3.5.10 Help(帮助)菜单

STM32CubeIDE的 Help(帮助)菜单提供多种资源和工具,帮助开发者快速获取支持

和信息。主要功能包括信息中心、视频教程、帮助内容、搜索、显示上下文帮助和活动键绑

定、提示和技巧、技巧表、Eclipse用户存储管理(如账户、收藏夹和注销)、检查和安装软件更

新、访问Eclipse市场、检查和管理嵌入式软件包、目标设备文档和资源、ST-LINK更新以及

关于STM32CubeIDE的信息。这些功能帮助开发者解决问题、获取最新资源和优化开发过程。

Help菜单如图3-78所示。

Help菜单功能说明如下。
(1)

 

Information
 

Center:
 

信息中心。
(2)

 

Video
 

tutorials:
 

视频教程。
(3)

 

Help
 

Contents:
 

帮助内容。
(4)

 

Search:
 

搜索。
(5)

 

Show
 

Context
 

Help:
 

显示上下文帮助。
(6)

 

Show
 

Active
 

Keybindings:
 

显示活动键绑定。
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图3-78 Help菜单

(7)
 

Tips
 

and
 

Tricks:
 

提示和技巧。
(8)

 

Cheat
 

Sheets:
 

技巧表。
(9)

 

Eclipse
 

User
 

Storage:
 

Eclipse用户存储,子菜单如图3-79所示。

图3-79 Help→Eclipse
 

User
 

Storage子菜单

①
 

Open
 

My
 

Account:
 

打开我的账户。

②
 

Open
 

Marketplace
 

Favorites:
 

打开市场收藏夹。

③
 

Sign
 

Out:
 

注销。
(10)

 

Check
 

for
 

Updates:
 

检查更新。
(11)

 

Install
 

New
 

Software:
 

安装新软件。
(12)

 

Eclipse
 

Marketplace:
 

Eclipse市场。
(13)

 

Check
 

for
 

Target
 

Selector
 

Device
 

Database
 

Updates:
 

检查目标选择器设备数据

库更新。
(14)

 

Check
 

for
 

Embedded
 

Software
 

Packages
 

Updates:
 

检查嵌入式软件包更新。
(15)

 

Manage
 

Embedded
 

Software
 

Packages:
 

管理嵌入式软件包。
(16)

 

Target
 

Device
 

Docs
 

and
 

Resources:
 

目标设备文档和资源。
(17)

 

About
 

STM32CubeIDE:
 

关于STM32CubeIDE。

3.6 STM32CubeIDE的操作

本节讲述STM32CubeIDE的操作,包括新建和导入工程、项目管理、打开/关闭/删除/
切换/导出工程、固件库管理、代码编译、调试及运行配置和启动调试。
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3.6.1 新建和导入工程

使用STM32CubeIDE,可以通过File菜单下的New或Import命令新建或导入一个项目。
也可以执行File→Open

 

Projects
 

from
 

File
 

System菜单命令,将一个项目导入当前工

作空间中,如图3-80所示。

图3-80 打开STM32CubeIDE工程

3.6.2 项目管理

一个工作空间可以管理多个项目,工作空间里的项目有打开和关闭两种状态。图3-81所

示为GPIO输出应用实例LED项目工程结构,在项目浏览器里,双击一个项目的节点就可以

打开项目,在项目节点上右击,在弹出的快捷菜单中单击Close
 

Project,就可以关闭这个项目。
当工作空间里有多个项目处于打开状态时,只有一个项目是当前项目,单击一个项目的

任何一个文件夹或文件节点,这个项目就变成当前项目。构建、项目属性设置、下载和调试

等项目操作都是针对当前项目的。所以,在工作空间中最好只打开一个当前需要处理的项

目,关闭其他项目。这样可以减少内存占用,并且可以避免未切换到真正需要处理的项目而

导致操作失误。
项目的管理可以通过主工具栏按钮、Project主菜单或项目浏览器中项目节点的快捷菜

单实现。图3-82所示为项目节点快捷菜单中的部分菜单项。常用的项目管理操作如下。
(1)

 

Build
 

All(构建全部):
 

构建工作空间中所有已打开的项目(位于Project主菜单

下)。所以,不要打开工作空间中不需要处理的项目。



134  

图3-81 LED项目工程结构
   

图3-82 项目节点的快捷菜单(部分项)

(2)
 

Build
 

Project(构建项目):
 

构建工作空间中的当前项目。构建后会在项目中生成

Debug或Release目录(由项目当前配置决定)和一个虚拟文件夹Binaries,这个虚拟文件夹

中是编译生成的二进制文件,如LED.elf。
(3)

 

Clean
 

Project(清理项目):
 

清除项目构建生成的中间文件和二进制文件。
(4)

 

Close
 

Project(关闭项目):
 

关闭当前项目。
(5)

 

Close
 

Unrelated
 

Projects(关闭不相关项目):
 

关闭工作空间中所有与本项目无关

的项目。
(6)

 

Refresh(刷新):
 

在使用独立的STM32CubeMX重新生成代码后,用户可能需要手

动刷新项目的文件。
(7)

 

Build
 

Automatically(自动构建):
 

这是一个复选项(位于Project主菜单下),如果

打开这个选项,在项目程序文件被修改,或STM32CubeMX重新生成代码后就会自动构建。
一般应关闭此选项,自行控制构建时机。

(8)
 

Properties(属性):
 

项目属性设置,快捷键为Alt+Enter,可用于打开一个属性设置

对话框,对项目的很多属性进行设置。

3.6.3 打开/关闭/删除/切换/导出工程

图3-83 STM32CubeIDE
 

工程浏览器

在Project
 

Explorer(工程浏览器)中可以看到当前

工作空间下的所有工程,如图3-83所示。用户可以对

这其中的任一工程进行打开/关闭/删除/切换/导出等

操作。STM32CubeIDE
 

工程浏览器如图3-83所示。

3.6.4 固件库管理

STM32CubeIDE集成了STM32CubeMX的部分
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功能,可以直接选择芯片/开发板型号,或者选择例程生成一个新工程。STM32CubeIDE生

成工程所需要的驱动和例程代码都来自各STM32系列的固件库。
执行Help→Manage

 

Embedded
 

Software
 

Packages菜单命令,可以对所有STM32固

件库以及其他的插件进行管理(安装/删除固件库)。STM32CubeIDE固件库管理如图3-84
所示。

图3-84 STM32CubeIDE固件库管理

用户可以通过Install按钮让STM32CubeIDE自动从网络进行下载安装,也可以通过

From
 

Local按钮安装已经预先下载好的固件库。通过Remove按钮可以删除选中的固件库。

3.6.5 代码编译

用户可以通过以下3种方法启动编译。
方法1:

 

选中工程,右击,从弹出的快捷菜单中选择Build
 

Project。
方法2:

 

选中工程,执行Project→Build
 

Project菜单命令。
方法3:

 

选中工程,直接单击工具栏里的Build图标。
工程编译完成以后,在Build

 

Analyzer窗口可以看到链接文件中定义的所有内存区域

(Memory
 

Region)和段(Section)的使用情况,包括加载地址、运行地址、有多少字节已经被

占用、还剩余多少字节等。STM32CubeIDE构建分析结果如图3-85所示。
在Static

 

Stack
 

Analyzer窗口中显示了静态堆栈的使用情况。STM32CubeIDE堆栈统

计分析如图3-86所示。
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图3-85 STM32CubeIDE构建分析结果

图3-86 STM32CubeIDE堆栈统计分析

3.6.6 调试及运行配置

STM32CubeIDE工程编译完成且无任何错误,就可以进行调试和下载了。
在C/C++透视图的工具栏中有3个和下载调试相关的按钮:

 

调试、运行和外部工具,如
图3-87所示。

图3-87 STM32CubeIDE调试/下载/工具配置说明

通过“调试”按钮旁边的下三角 ,可以弹出Debug
 

Configurations对话框,进行调试参

数的配置,如调试器的选择、GDB连接的设置、ST-LINK的设置、外部Flash
 

Loader的设定

等,并启动调试。Debug
 

Configurations对话框如图3-88所示。
通过“运行”按钮,可以仅下载程序,不启动调试。
通过“外部工具”按钮,可以调用外部的命令行工具。

3.6.7 启动调试

在STM32CubeIDE中启动调试非常简单。首先,打开项目,确保代码已经编译无误。
接着,连接STM32开发板到计算机,并在STM32CubeIDE中选择相应的调试配置,如
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图3-88 Debug
 

Configurations对话框

ST-LINK。单击工具栏上的Debug按钮,启动调试会话。STM32CubeIDE会自动下载程

序到目标板,并进入调试模式,用户可以设置断点、单步执行代码、观察变量和寄存器等。整

个过程直观高效,有助于快速定位和解决问题。

1.
 

仿真器检测和固件升级

下载程序之前,需要用仿真器连接计算机和开发板,还要在计算机上安装仿真器的驱动

图3-89 Help→ST-LINK更新

程序。STM32CubeIDE只支持ST-LINK仿真器,
在首次使用仿真器之前,用户还需要检查仿真器固

件版本是否符合STM32CubeIDE的要求。方法是

执行Help→“ST-LINK更新”菜单命令,如图3-89
所示。

执行Help→“ST-LINK更新”菜单命令后,弹
出STLinkUpgrade

 

3.4.0对话框,如图3-90所示

的。在此对话框中,软件会显示自动发现的仿真器

类型,如图3-90中下拉列表框里的ST-LINK/V2。
单击Open

 

in
 

update
 

mode按钮,如果仿真器与计

算机连接正常,会显示仿真器类型和当前版本,以
及可以升级到的固件版本。如果当前版本低于可

升级版本,就需要升级仿真器的固件,单击 Upgrade按钮就可以开始升级。仿真器固件升

级一次即可,除非有新的固件版本需要升级。特别需要注意的是,ST-LINK/V2仿真器一

定不能连接开发板,待ST-LINK/V2仿真器升级完成后,再连接开发板。
用户还可以检测仿真器连接是否正常。有时仿真器虽然连接着计算机,但是无法正常
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图3-90 升级仿真器固件

下载程序。打开仿真器固件升级对话框后,单击Open
 

in
 

update
 

mode
 

按钮,如果软件无法

检测到仿真器固件版本,并且在窗口下方显示信息“ST-LINK
 

is
 

not
 

in
 

the
 

DFU
 

mode.
 

Please
 

restart
 

it”,这就说明仿真器连接出现了问题。这种情况下,从 USB接口拔掉仿真

器,然后重新插上就可以了。

STM32CubeIDE使用GDB进行调试,支持ST-LINK调试器,支持通过SWD或JTAG
接口连接目标 MCU。

2.
 

程序下载

构建项目无误后,就可以下载程序到开发板上进行调试了。下载程序之前,可以先在源

代码中设置断点,当输入光标在某一有效代码行时,按Ctrl+Shift+B快捷键就可以在当前

图3-91 Debug菜单

行设置或取消断点。
单击主工具栏上的“调试”按钮就可以启动程序下载和调试。
单击“调试”按钮 右侧的下三角 ,弹出如图3-91所示

的Debug菜单,用于调试设置(Debug
 

Configurations)。
单击Debug

 

Configurations菜单项,会弹出如图3-92所示的

Debug
 

Configurations对话框。

Debug
 

Configurations对话框用于设置调试相关的一些参数,所显示的“调试器”标签

页的设置都是默认设置。“调试探头”下拉列表用于选择仿真器类型,只有ST-LINK和

J-LINK可选(实际上只能用ST-LINK),因为STM32CubeIDE只支持这两种仿真器。调试

器有SWD和JTAG两种接口,这个会自动与STM32CubeMX里设置的调试接口一致。对

于STM32F407开发板,我们应该使用SWD接口。Reset
 

behaviour的Type下拉列表用于

设置下载程序时的复位方式,使用默认的Connect
 

under
 

reset即可,而且在调试低功耗程序

时,必须使用这种方式。
其他标签页的设置也都保持默认设置即可,然后单击OK按钮,会弹出一个提示对话

框,提示会切换到Debug场景,确认后软件界面就会切换为Debug场景。
首次启动调试后,系统会在项目根目录下创建一个扩展名为.launch的文件,这是记录

调试配置的启动文件。下次再单击工具栏上的Debug按钮,就可以直接下载程序并进入调
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图3-92 Debug
 

Configurations对话框

试状态,无须再设置。

STM32CubeIDE工程编译完成之后,直接单击工具栏的“调试”按钮 或执行Run→
Debug菜单命令,可以启动调试。

3.
 

Debug场景界面和调试操作

下载程序后,软件自动切换到Debug场景界面,如图3-93所示。主工具栏的按钮自动

图3-93 Debug场景界面
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更换了一批,界面上出现了一些调试时用的视图。例如,Variables(变量)视图可以自动显

示当前函数内变量的值,Expressions(表达式)视图可以自己添加观察变量,Breakpoints(断
点)视图可以添加或移除断点,Registers(寄存器)视图会显示CPU寄存器的内容,SFRs(特
殊功能寄存器)视图会显示 MCU上的各种特殊功能寄存器的内容。这些视图的操作就不

具体介绍了,用户自己摸索操作一下就可以掌握。
在Debug场景里,Run主菜单包含所有调试操作菜单项,主工具栏上也有一些常用的

调试操作按钮,这些按钮的功能如表3-3所示。程序单步调试和断点调试的方法与一般的

IDE软件里的程序调试方法是一样的,这里就不再具体介绍。

表3-3 用于调试操作的工具栏按钮的功能

图标 提示文字 快捷键 功
 

能
 

说
 

明

Skip
 

All
 

Breakpoints Ctrl+Alt+B 一个复选按钮,按下后将忽略所有断点

Terminate
 

and
 

relaunch — 终止程序,重新下载程序后开始调试

Resume F8 从当前停止的行开始,继续连续运行

Suspend — 程序挂起

Terminate Ctrl+F2
终止程序执行,并退出Debug场景,返回C/C++
场景

Disconnect — 断开连接,并退出Debug场景,返回C/C++场景

Step
 

Into F5
若当前行是一个函数调用,将会跳转进入此函数

的代码内执行

Step
 

Over F6

一步执行当前行程序,不管是否有函数调用。如

果执行的函数里有断点定义,会执行到断点处

暂停

Step
 

Return F7
如果当前代码段是跳转进来的一个函数,单击此

按钮可以执行完此函数的代码,返回到上一层

Run
 

to
 

Line Ctrl+R 运行到光标所在的行

Instruction
 

stepping
 

mode
—

进入反汇编(Disassembly)视图,单步调试汇编

语言指令

Reset
 

the
 

chip
 

and
 

restart
debug

 

session
— 芯片复位,重新开始调试过程

进入Debug场景后,程序会停在main()函数的第一行代码处。用户可以单步调试,也
可以按F8快捷键使程序连续运行。

如果是第一次对当前工程进行调试,STM32CubeIDE会先编译工程,然后打开调试配

置窗口。调试配置窗口包含调试接口的选择、ST-LINK的设置、复位设置和外部Flash
 

Loader的设置等选项,用户可以检查或者修改各项配置。确认所有配置都正确无误,就可

以单击OK按钮,启动调试。
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STM32CubeIDE会先将程序下载到 MCU,然后从链接文件(*.ld)中指定的程序入口

开始执行。程序默认从Reset_Handler开始执行,并暂停在 main()函数的第一行,等待接

下来的调试指令。
启动调试后,STM32CubeIDE将自动切换到调试透视图,在调试透视图的工具栏中,列

出了调试操作按钮,如图3-94所示。

图3-94 STM32CubeIDE调试工具栏说明

3.7 使用内置的STM32CubeMX

STM32CubeIDE是基于Eclipse的软件,Eclipse可以安装各种插件扩展功能。用户可

以在TrueSTUDIO中安装STM32CubeMX插件,实现在TrueSTUDIO 中使用STM32CubeMX。

STM32CubeIDE中集成了STM32CubeMX,实际上就是预装了STM32CubeMX插件。

ADC项目结合使用了独立的STM32CubeMX和STM32CubeIDE,也可以直接使用
 

STM32CubeIDE内置的STM32CubeMX,其用法基本也是一样的。但是在实际使用中,使
用内 置 的 STM32CubeMX 不 如 使 用 独 立 的 STM32CubeMX 方 便,因 为 使 用 独 立 的

STM32CubeMX软件,界面更大一些,在两个软件之间切换和对比也方便,而且内置的

STM32CubeMX只能导出STM32CubeIDE项目代码,而独立的STM32CubeMX可以生成

各种IDE软件的项目代码。
但是,作为一个功能,下面也介绍一下内置STM32CubeMX的使用。要在STM32CubeIDE

中使用内置的STM32CubeMX配置 MCU和生成代码,也需要配置软件库目录,安装 MCU
固件库。前面介绍了配置软件库目录的方法,与独立的STM32CubeMX使用同一个软件库

即可。

3.7.1 创建项目

从头开始在STM32CubeIDE中创建一个使用STM32
 

MCU的TESTLED项目,实现

功能与LED项目相同。单击STM32CubeIDE的“信息中心”按钮 (Information
 

Center),
弹出STM32CubeIDE内嵌STM32CubeMX界面,几乎与独立的STM32CubeMX界面是一

样的。
首先在F盘创建一个文件夹DemoLED。
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在STM32CubeIDE中执行File→New→STM32
 

Project菜单命令,如图3-95所示。

图3-95 New→STM32
 

Project菜单命令

然后,进入如图3-96所示的STM32
 

Project对话框,MCU/MPU
 

Selector标签页用于

选择一个 MCU或 MPU创建项目。

图3-96 选择 MCU/MPU

选择STM32F407ZGT6,然后单击Next按钮,设置项目名称,如TESTLED,如图3-97
所示。如果勾选了Use

 

default
 

location复选框,就会在当前工作空间的目录下创建与项目

名称同名的子目录。Options区域有3个选项,使用图3-97的设置即可,如果需要使用

C++编程,可以选择C++。
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用户可以单击Finish按钮直接创建项目,也可以单击Next按钮,设置固件版本和生成

代码的选项,如图3-98所示。

图3-97 设置项目名称

图3-98 固件版本和生成代码选项设置
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单击Finish按钮,将创建TESTLED项目,加载IOC,如图3-99所示。

图3-99 加载IOC

创建TESTLED项目完成,在项目浏览器中打开这个项目,自动切换到
 

Device
 

Configuration
 

Tool场景,如图3-100所示。

图3-100 新建项目后的Device
 

Configuration
 

Tool场景
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3.7.2 配置 MCU和生成代码

图3-100所示的项目浏览器显示了TESTLED项目的目录结构。这个项目的根目录下

有一个\Core目录,这个目录下有3个子目录\Inc、\Src和\Startup。
图3-100 中 的 工 作 区 是 STM32CubeMX 视 图,用 于 配 置 TESTLED.ioc文 件。

STM32CubeMX视图的界面和操作功能与独立的STM32CubeMX软件基本相同,只是这

里没有生成代码的按钮,项目浏览器里生成项目的IDE软件固定为STM32CubeIDE,不能

选择其他IDE软件。
此处不再赘述在STM32CubeMX视图中进行 MCU配置的操作,请参考STM32CubeMX

的内容。本项目 MCU的具体设置与项目LED的完全相同,设置内容如下。
(1)

 

RCC组件的HSE设置为Crystal/Ceramic
 

Resonator,不启用LSE。
(2)

 

在时钟配置页面,将 HSE设置为8MHz,选择 HSE作为主锁存器的时钟源,将

HCLK
 

设置为168MHz,由软件自动设置时钟树各种参数。
(3)

 

在SYS组件的模式设置中,将Debug
 

接口设置为Serial
 

Wire。
(4)

 

在引脚视图上,直接将PF6、PF7和PF8引脚设置为GPIO_Output,并修改用户标

签为LED1、LED2和LED3。
(5)

 

在GPIO组件的配置页面,对PF6、PF7和PF8引脚的GPIO属性进行设置。
在单击保存文件时,用户会收到是否生成代码的提示,可以选择生成代码,也可以执行

Project→Generate
 

Code菜单命令(快捷键
 

Alt+K)或按工具栏上的按钮生成代码。生成代

码后再进行构建、下载和调试。
对于使用独立的STM32CubeMX软件生成的LED项目,在STM32CubeIDE的项目浏

览器里双击项目LED.ioc文件时,也会用STM32CubeMX视图打开这个文件,也可以进行

配置和生成代码,生成代码时不会破坏项目原来的文件组织结构。
虽然可以使用内置的STM32CubeMX在STM32CubeIDE里创建STM32项目,但是

一般多采用独立的STM32CubeMX软件。

3.8 STM32CubeIDE
 

使用偏好设置

STM32CubeIDE是比较庞大的IDE软件,执行 Window→Preferences菜单命令,弹出

Preferences对话框,就可以对软件环境进行很多设置。我们之前在这个对话框里设置过软

件库目录和更新方式,这里再介绍几个比较有用的设置。
用户可以在Preferences对话框左侧目录树上方的文本框里输入搜索关键字。如图3-101

所示,输入startup进行搜索,并单击Startup
 

and
 

Shutdown节点。这里设置软件启动时启

动的插件,这些插件默认是都启动的。启动的插件越多,软件启动越慢,占用的内存越多。
用户可以将一些不常用的插件设置为不启动。例如,图3-101中只保留了两个插件启动,这
两个插件是构建和调试STM32项目必需的。STM32CubeMX

 

插件也没有设置为启动,在
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STM32CubeIDE里双击一个.ioc文件时,STM32CubeMX插件才会启动。

图3-101 软件启动插件设置

图3-102所示为最近使用工作空间的设置,可以设置保存最近使用工作空间的个数、是
否在软件启动时提示选择工作空间,也可以清空最近使用的工作空间列表。

图3-102 最近使用工作空间的设置
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在文本框中输入fold进行搜索,进入如图3-103所示的代码折叠设置页面。图3-103
中的第二个和第三个复选框默认是不勾选的,勾选这两个复选框对于查看和分析代码比较

有用。

图3-103 代码折叠设置页面

Preferences对话框还有很多设置功能,主菜单里也还有很多功能,无法在此全部介绍,
读者可以自己在使用中逐步摸索和发现。

3.9 STM32F407开发板的选择

本书应用实例是在野火F407-霸天虎开发板上调试通过的,该开发板可以网上购买,价
格因模块配置的区别而不同,一般为500~700元。

野火F407-霸天虎开发板使用STM32F407ZGT6作为主控芯片,使用3.3英寸液晶屏

进行交互;
 

可通过 Wi-Fi形式接入互联网,支持使用串口(TTL)、RS-485、CAN、USB协议

与其他设备通信;
 

板载Flash、EEPROM、全彩RGB
 

LED灯;
 

还提供了各式通用接口,能满

足各种各样的学习需求。
野火F407-霸天虎开发板如图3-104所示。
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图3-104 野火F407-霸天虎开发板(带TFT
 

LCD)

3.10 STM32仿真器的选择

1.
 

ST-LINK/V2仿真器

ST-LINK是ST公司为STM8和STM32系列微控制器设计的仿真器。ST-LINK/V2
仿真器如图3-105所示。

ST-LINK仿真器具有如下特点。
(1)

 

编程功能:
 

可烧写Flash
 

ROM、EEPROM等,需要安装驱动程序才能使用。
(2)

 

仿真功能:
 

支持全速运行、单步调试、断点调试等调试方法。
(3)

 

可查看I/O状态、变量数据等。
(4)

 

仿真性能:
 

采用USB
 

2.0接口进行仿真调试、单步调试、断点调试,反应速度快。
(5)

 

编程性能:
 

采用USB
 

2.0接口,进行
 

SWIM/JTAG/SWD下载,下载速度快。
2.

 

微控制器调试接口

STM32系列微控制器调试接口引脚图如图3-106所示。为了减少PCB的占用空间,
JTAG调试接口可用双排10引脚接口,SWD调试接口只需要SWDIO、SWCLK、RESET和

GND这4根线。

图3-105 ST-LINK/V2仿真器 图3-106 STM32系列微控制器调试接口引脚图


